[Ffmpeg-cvslog] r6213 - in trunk: Changelog MAINTAINERS doc/ffmpeg-doc.texi libavcodec/Makefile libavcodec/allcodecs.c libavcodec/avcodec.h libavcodec/vp5.c libavcodec/vp56.c libavcodec/vp56.h libavcodec/vp56data.c libavcodec/vp56data.h libavcodec/vp5data.h libavcodec/vp6.c libavcodec/vp6data.h libavformat/flvdec.c libavformat/nsvdec.c libavformat/riff.c libavformat/swf.c

Luca Barbato lu_zero
Sun Sep 10 13:33:23 CEST 2006

Rich Felker wrote:
> On Sat, Sep 09, 2006 at 11:47:38PM +0200, Luca Barbato wrote:
>> vector is/should be a define not a keyword, same as pixel.
>> I'd rename it nonetheless.
> Then where is it getting defined?


#if !defined(__APPLE_ALTIVEC__)
/* You are allowed to undef these for C++ compatibility.  */
#define vector __vector
#define pixel __pixel
#define bool __bool

You know already that I don't like that much gcc-apple.



Luca Barbato

Gentoo/linux Gentoo/PPC

More information about the ffmpeg-cvslog mailing list