[FFmpeg-cvslog] r15002 - in trunk/libavformat: internal.h sdp.c utils.c
Sat Aug 30 14:00:17 CEST 2008
On date Saturday 2008-08-30 11:51:32 +0100, M?ns Rullg?rd wrote:
> "Ronald S. Bultje" <rsbultje at gmail.com> writes:
> > Hi Stefano,
> > On Fri, Aug 29, 2008 at 10:51 PM, Stefano Sabatini
> > <stefano.sabatini-lala at poste.it> wrote:
> >> On date Friday 2008-08-29 19:51:24 -0400, Ronald S. Bultje wrote:
> >>> On Fri, Aug 29, 2008 at 7:29 PM, Stefano Sabatini
> >>> <stefano.sabatini-lala at poste.it> wrote:
> >>> @@ -3075,4 +3075,4 @@
> >>> #define AVERROR_NOENT AVERROR(ENOENT) /**< No such file or directory. */
> >>> #define AVERROR_PATCHWELCOME -MKTAG('P','A','W','E') /**< Not yet
> >>> implemented in FFmpeg. Patches welcome. */
> >>> -#endif /* FFMPEG_AVCODEC_H */
> >>> +#endif /* AVCODEC_AVCODEC_H */
> >>> That's kind of ugly?
> >> No I think it's pretty regular and simple -> nice, cannot see other
> >> rules which are both straightforward and don't lead to possible name
> >> conflicts.
> > LIBAVCODEC_AVCODEC_H? Double AVCODEC is ugly. Anyway, minor, rest of
> > the work is nice. :-). I guess I was just wondering if others agreed.
> We *could* use just AVCODEC for avcodec.h, and do similarly for the
> other headers with names matching the libs.
I don't like this so much, using this rule for example we would have:
libavfilter/avfilter.h -> AVFILTER_H
libavfilter/avfiltergraph.h -> AVFILTER_AVFILTERGRAPH_H
looks inconsistent/ugly to me, I read AVFILTER_AVFILTER_H as
avfilter.h defined in libavfilter guard, so I don't consider it like a
repetition but rather as useful information.
Anyway I'm ready to change the rule if more developers insist on
More information about the ffmpeg-cvslog