[FFmpeg-cvslog] dv: Replace a magic number by sizeof()

Diego Biurrun git at videolan.org
Thu Jun 26 03:23:43 CEST 2014


ffmpeg | branch: master | Diego Biurrun <diego at biurrun.de> | Fri Feb  7 10:42:35 2014 +0100| [593d2326ef985cdffe413df629419938f7b07c4c] | committer: Diego Biurrun

dv: Replace a magic number by sizeof()

> http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=593d2326ef985cdffe413df629419938f7b07c4c
---

 libavcodec/dv.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libavcodec/dv.c b/libavcodec/dv.c
index 03ef695..e840f48 100644
--- a/libavcodec/dv.c
+++ b/libavcodec/dv.c
@@ -307,7 +307,7 @@ av_cold int ff_dvvideo_init(AVCodecContext *avctx)
     /* 248DCT setup */
     s->fdct[1]     = dsp.fdct248;
     s->idct_put[1] = ff_simple_idct248_put;  // FIXME: need to add it to DSP
-    memcpy(s->dv_zigzag[1], ff_dv_zigzag248_direct, 64);
+    memcpy(s->dv_zigzag[1], ff_dv_zigzag248_direct, sizeof(s->dv_zigzag[1]));
 
     s->avctx = avctx;
     avctx->chroma_sample_location = AVCHROMA_LOC_TOPLEFT;



More information about the ffmpeg-cvslog mailing list