[Ffmpeg-devel-irc] ffmpeg.log.20111121

burek burek021 at gmail.com
Tue Nov 22 02:05:01 CET 2011

[00:00] <teratorn> (by arbitrary angles)
[00:04] <LikWidChz> like rotate 361 degrees?
[00:06] <pasteeater> i don't think so. 'transpose' is 90 increments. unless there is something in the frei0r or mp filter sets.
[00:06] <pasteeater> *90 degree
[00:10] <teratorn> I've been poking around but I don't see anything
[00:11] <teratorn> LikWidChz:  1 <= x <= 359
[00:20] <LikWidChz> heh yeah I know
[00:28] <LikWidChz> is there anyway ffmpeg can process a file list?
[00:29] <LikWidChz> the linux vm option wont work for me :\ gotta be in windows
[01:57] <burek> LikWidChz, make a for loop
[02:27] <LikWidChz> yeah I made a batch file with %1 - %20 and just drag 20 files ontop of it at a time
[02:27] <burek> you can use shift
[02:27] <LikWidChz> ?
[02:27] <burek> to avoid 20 files limit
[02:27] <LikWidChz> well humor me on what to do im all ears
[02:28] <burek> http://www.robvanderwoude.com/parameters.php
[02:28] <LikWidChz> I find it funny how these applications written around ffmpeg suck and the cli option is eaysier... same thing with mdadm for linux... its like once you know how to do it use it
[02:28] <burek> ?=
[02:28] <burek> :)
[02:28] <LikWidChz> I know right
[02:29] <burek> the worst thing is, when ffmpeg changes something, you have to wait until the wrapper updates too
[02:29] <LikWidChz> honestly FFmpeg should be allowed a list input
[02:29] <LikWidChz> or -D process directory
[02:30] <burek> well, you can always file a feature suggestion :)
[02:30] <burek> but in fact, is it so hard to use a loop? :)
[02:30] <LikWidChz> well honestly I have ideas... BUT... I Cant think that my idea is new...
[02:30] <LikWidChz> its not hard, I just dont know how
[02:30] <burek> in windows?
[02:30] <LikWidChz> lemme tell you what im doing
[02:30] <burek> ok
[02:31] <LikWidChz> yes unfortunatly
[02:31] <LikWidChz> this is what I have
[02:31] <LikWidChz> ffmpeg -i %1 -s 720x400 -vcodec libx264 -b 1700k -acodec libmp3lame -ab 128k %1.mkv
[02:31] <LikWidChz> i end up with file.avi     output is file.avi.mkv which is sloppy but i dont know how else to do it
[02:32] <LikWidChz> funny thing is, I was actually VERY impressed with how good that 1700kbit output looks like
[02:32] <burek> try also with -preset and -tune
[02:32] <LikWidChz> what do those do?
[02:33] <LikWidChz> haha dont tell me tune it and lay down a preset :)
[02:34] <LikWidChz> where do I put in the two extra options?
[02:35] <burek> just a sec
[02:36] <burek> http://pastebin.com/vrzum8uY
[02:37] <burek> http://mewiki.project357.com/wiki/X264_Settings
[02:38] <burek> -profile, -preset and -tune you can put after -vcodec libx264
[02:38] <LikWidChz> FANCY!
[02:38] <Wildride> how come this does not work?  ffmpeg -i E:\ace.mkv -acodec copy E:\ace.m4a
[02:39] <sacarasc> Wildride: You tell us.
[02:39] <LikWidChz> haha whats placebo as a preset?
[02:39] <LikWidChz> and what difference really does the encoding preset do for you?
[02:39] <burek> Wildride, please use pastebin.com so we can see the output
[02:39] <burek> dont use placebo
[02:40] <burek> unless you are testing stuff
[02:40] <LikWidChz> hahaha I know but its funny
[02:40] <burek> preset sets all those options for encoding
[02:40] <sacarasc> LikWidChz: The presets are different speeds with which to encode. The faster they are the worse quality and the slower the better, but placebo is a tiny gain for a LOT more time encoding.
[02:40] <Wildride> http://pastesite.com/28432
[02:41] <LikWidChz> ahh gotcha
[02:41] <LikWidChz> will i notice a difference with tune?
[02:42] <burek> Wildride ffmpeg -i E:\ace.mkv -vn -acodec copy E:\ace.m4a
[02:42] <Wildride> what is vn
[02:42] <burek> no video
[02:42] <Wildride> does not work
[02:42] <burek> LikWidChz, no you wont, its there just for fun ^^
[02:43] <burek> it does work :)
[02:43] <burek> its just your ffmpeg is probably old
[02:43] <LikWidChz> haha seriously? Im not sure where you put in tune though which looks like it should be --preset
[02:43] <Wildride> track 0: output format does not support sample rate 96000hz
[02:44] <burek> Wildride, try: ffmpeg -i E:\ace.mkv -vn -acodec copy E:\ace.mp4
[02:44] <Wildride> still not work
[02:45] <burek> why in the world would someone encode audio in 96000 Hz
[02:45] <burek> Wildride, what exactly is your goal
[02:45] <Wildride> get audioonly file without encoding
[02:46] <burek> since it is aac
[02:46] <burek> you could try with .aac
[02:46] <burek> ffmpeg -i E:\ace.mkv -vn -acodec copy E:\ace.aac
[02:48] <LikWidChz> humm Is the difference seen in CBR when going from the default preset medium to faster going to be in the high motion scenes?
[02:48] <burek> if you use cbr (constant bit rate) then what difference are you talking about
[02:49] <sacarasc> burek: The preset differences.
[02:49] <burek> faster = bigger file size = less encoding = faster :)
[02:49] <LikWidChz> well yeah, I mean honstly im pretty amazed with the quality of it now, but what is the preset actually changing? besides encode speed
[02:50] <burek> -crf changes the quality (as I figured so far)
[02:50] <burek> -preset changes speed
[02:50] <LikWidChz> if I do veryslow vs ultrafast @ cbr of 1700k i would imagine the file size should be the same
[02:50] <burek> oh i see
[02:51] <relaxed> no, veryslow offers much greater compression
[02:51] <Wildride> burek how do i do  video-only
[02:51] <burek> Wildride, since it is h264
[02:51] <burek> ffmpeg -i E:\ace.mkv -an -vcodec copy E:\ace.h264
[02:53] <Wildride> burek i cannot play the .h264 file
[02:53] <LikWidChz> relaxed -- if I have my bitrate set at 1700k it should be that size when its done and not be smaller then if I set 1700k at very fast
[02:53] <burek> relaxed, does it keep the same quality (but doesnt compress it too much)
[02:53] <burek> Wildride, use .mp4
[02:53] <burek> or .264
[02:54] <burek> i mean, does -preset change the quality of the image or just the compression level
[02:56] <relaxed> mostly it controls compression. -crf or -b control quality
[02:57] <LikWidChz> burek -- I did a quick test between normal and ultra fast.... big difference
[02:57] <pasteeater> the preset can change the quality, but it should be so little that it's not worth worrying about
[02:57] <LikWidChz> I would have to argue it changes the quality of each frame
[02:57] <burek> ok, so, is it safe to use something like -preset veryfast -crf 20
[02:57] <LikWidChz> with it being set faster, you see more compression blocks in the output
[02:58] <kkk> For all Dexter Freaks: http://online-stream.tv/ ON JTV-Rip channel airs the new episode in 2 minutes
[02:58] <LikWidChz> kkk is that live streamed or something?
[02:58] <kkk> yes it is
[02:58] <LikWidChz> funny stuff
[02:59] <kkk> with ffmpeg dude
[02:59] <kkk> ^^
[02:59] <Wildride> does ffmpeg.exe support splitting audio file 
[02:59] <LikWidChz> hahahahah thats great
[03:00] <kkk> i'll watch dexter ^^ cya guys
[03:02] <LikWidChz> bahh ill just wait an hour until someone cuts out all the commercials
[03:02] <LikWidChz> burek -- thankyou for that batch file
[03:03] <burek> :beer: :)
[03:04] <Wildride> does ffmpeg.exe support splitting audio file ; i just want the first from  0 to 15 seconds
[03:04] <burek> yes it does
[03:04] <burek> http://ffmpeg.org/ffmpeg.html
[03:04] <burek> you are looking for -ss and -t
[03:04] <burek> and -vn
[03:05] <LikWidChz> i think im going to go with faster, I think the slower you get the more and more diminising the returns are...... However I think it would make a big difference going from 2x HD resolution to HD ... btw whats this crf option? I might experiment with this next
[03:05] <burek> actually if its from 0-15, then only -t is enough
[03:05] <burek> constant rate factor
[03:05] <burek> it keeps the "constant" quality throughout the video
[03:06] <burek> usually -crf 20 is good enough
[03:06] <LikWidChz> Oh OH! I remember this I would always mess around with this option in CCE that mpeg2 video encoder
[03:06] <LikWidChz> the bitrate would be shifted from the complicated parts to the flat non complicated parts
[03:06] <burek> yes
[03:06] <LikWidChz> Id rather have adaptive quanitization
[03:06] <burek> dont confuse it with -cqp (const quantization param)
[03:07] <LikWidChz> wait what is it by default?
[03:07] <burek> http://ffmpeg.org/ffmpeg.html
[03:07] <burek> :)
[03:07] <LikWidChz> still looking at that site you posted eairler
[03:07] <LikWidChz> infact would be nice to see screenshot comparisons
[03:07] <LikWidChz> remeber what they always did screenshots off... the matrix dvd... that would be legal to do now right? ;)
[03:08] <pasteeater> comparisons between what?
[03:08] <LikWidChz> input options and output results
[03:10] <LikWidChz> anyway this encoding is very interesting stuff.... cant wait to see whats next on the horizon with video compression
[03:11] <burek> you could use this if you like to test stuff: https://sites.google.com/site/linuxencoding/x264-ffmpeg-mapping
[03:11] <LikWidChz> omg thats a crap ass load of options
[03:11] <Wildride> what is best website to upload 15 second audio file sample
[03:12] <LikWidChz> paste the hex in paste bin :) hahaha
[03:12] <Wildride> LikWidChz are you kidding me?
[03:12] <LikWidChz> yes I am
[03:12] <LikWidChz> try zshare.net
[03:12] <LikWidChz> for mp3s theres a play button
[03:13] <burek> ^^
[03:13] <LikWidChz> damn thats funny
[03:15] <Wildride> anybody know why so many player cannot play this file?  http://www.cpdtn.com/ace3.mp4
[03:16] <burek> is the audio encoded at 98000 Hz ?
[03:16] <burek> 96*
[03:16] <LikWidChz> it plays for me, then crashes media player classic
[03:16] <Wildride> yes and no
[03:17] <Wildride> when it plays it shows as 44khz
[03:17] <Wildride> when it does not play; it shows as 96khz
[03:17] <LikWidChz> hahahaha
[03:17] <LikWidChz> that sounds retarded :)
[03:17] <burek> try vlc
[03:17] <Wildride> likwidchz yes it does; but i am just stating facts
[03:18] <LikWidChz> yes I know I know... 
[03:28] <Wildride> does ffmpeg support  encoding to aac-LTP
[03:46] <Wildride> http://www.cpdtn.com/ace3.mp4  = is this 44 khz or 96 khz  ; i  am confused
[04:01] <mrmowgli> Whooo I am having massive linking problems, and I think it's because the libs I am linking against (vorbis, x264) compile fine, but are finding the system libs when linking, not the ones in /usr/local, any ideas on how to resolve this??? 
[04:01] <mrmowgli> http://www.pasteall.org/26619
[10:20] <daurnimator> when did AV_SAMPLE_FMT_U8 get it's AV_ added or removed?
[10:22] <ubitux> daurnimator: 262d1c5d, see "2010-11-02 - r25652 - lavcore 0.10.0 - samplefmt.h" in doc/APIChanges
[10:22] <ubitux> so about one year ago
[10:23] <daurnimator> ubitux: thanks :)
[10:23] Action: daurnimator is happily correct; and the user outdated :)
[12:26] <vivienschilis> hey guys
[12:26] <vivienschilis> weird issue with ffprobe
[12:27] <vivienschilis> if you ffprobe http://panda-test-harness-videos.s3.amazonaws.com/panda.mp4
[12:27] <vivienschilis> you will see width 300
[12:27] <vivienschilis> but ffprobe -show_streams will return 304 :S
[12:27] <vivienschilis> it is the same for you
[12:27] <vivienschilis> (master git)
[13:01] <vivienschilis> anyone?
[13:24] <fish_> hi
[13:34] <fish_> looks like ubuntu 10.04's ffmpeg has disabled the opencore amr libs...
[13:47] <fish_> if I install opencore amr codecs for example, is ffmpeg able to detect and use them on runtime? or is it necessary to compile support for that in?
[13:49] <torl> gu
[13:49] <torl> hi
[13:49] <relaxed> fish_: latter
[13:49] <torl> how can I run an .mp3 several times in a new file, looping over and over for x times ?
[13:50] <fish_> relaxed: so ubuntu just don't care for amr support in ffmpeg? ;)
[13:50] <relaxed> torl: ffmpeg -h | grep loop
[13:50] <fish_> (yes I know the patent issues, just wanna make sure I got this right)
[13:51] <relaxed> I don't use ubuntu and have no idea why
[13:54] <torl> how can I cut a part from an .mp3, say from 0:03 to 0:25 ?
[13:56] <relaxed> I would use sox for that
[13:56] <Tjoppen> -ss 3 -t 22
[13:56] <Tjoppen> but yeah, sox is a better fit for doing audio stuff
[13:57] <relaxed> the problem I ran into was ffmpeg isn't very accurate for cutting audio.
[13:59] <Tjoppen> indeed
[14:01] <torl> how can I modify the comments in an mp3 file, like genre, album, name etc ?
[14:02] <tdr> id3tag
[14:02] <relaxed> torl: look at the man page
[14:03] <torl> also why doesn't -loop 5 work ?
[14:03] <torl> the command I used is 
[14:03] <torl> ffmpeg -i 1.mp3 -loop 5 2.mp3
[14:04] <torl> the man says -loop_input and -loop_output are deprecatedf
[15:32] <fris> looking for the best way to convert m4a to mp3, whats better, ffmpeg -i input.m4a -sameq output.mp3 or ffmpeg -i input.m4a -acodec libmp3lame -ab 128k output.mp3
[15:33] <relaxed> ffmpeg -i input.m4a -acodec libmp3lame -aq 0 output.mp3
[15:34] <fris> whats the difference between them?
[15:35] <relaxed> -ab 128k is a little low, -sameq does nothing and -aq 0 uses the highest quality vbr encoding
[15:36] <fris> ahh ok thought -sameq did the same as the input
[15:40] <relaxed> fris: Everyone thinks that. I've never seen anyone use it correctly in all my time here. 
[15:54] <vivienschilis> anyone interested about an ffprobe issue :)
[16:26] <gearaholic> I have a corrupted MXF container file with a video using dvvideo codec.  is there any way i can just stream the contents of the file to ffmpeg and have it recover any usable data?
[16:27] <Tjoppen> corrupted how?
[16:28] <Tjoppen> you could possibly dd out the dv data in it
[16:29] <gearaholic> Im looking into that right now,  trying to find where the DV data starts.  just wondering if ffmpeg had a shortcut
[16:30] <gearaholic> the mxf file wont import into any programs we have tried
[16:30] <gearaholic> says it's not valid
[16:30] <Tjoppen> what does ffprobe say about it?
[16:31] <gearaholic> f15876864.mxf: Operation not permitted
[16:31] <Tjoppen> nothing more?
[16:31] <gearaholic> nope
[16:31] <gearaholic> im using 0.8.6
[16:31] <Tjoppen> what do the first couple of hexdump lines look like?
[16:32] <gearaholic> it has the right file header for a mxf file  starts with 06 0E 2B 34
[16:33] <gearaholic> even says panasonic p2 further down
[16:34] <gearaholic> this was a file recoverd from a damaged P2 card,  just trying to salvage a days worth of shooting video offsite
[16:34] <gearaholic> for a client
[16:35] <Tjoppen> what about mxfdump/mxfsplit?
[16:35] <Tjoppen> (mxflib)
[16:35] <gearaholic> havnt tried those,  i'll take a look
[16:36] <Tjoppen> mxfsplit will demux the essence streams into separate files
[16:36] <Tjoppen> should handle both opatom and op1a
[16:39] <gearaholic> mxfsplit is saying Partition    2 at 0x1834ca00 for BodySID 0x0000 No Body in this Partition 
[16:40] <Tjoppen> try finding the body partition, then dd it to a separate file
[16:40] <Tjoppen> then feed that into ffmpeg. sometimes it sort of figures out that the file is dv
[16:41] <gearaholic> ok thanks
[16:41] <Tjoppen> if you cut the file correctly you should get the dv essence actually - look for dv headers (I forget the hex values)
[16:42] <gearaholic> I do have a known good mxf file.  if i split that would i get the raw dv file to get the hex data from?
[16:43] <Tjoppen> yes
[16:43] <Tjoppen> you can then search for the first couple of bytes in the broken file using a hex editor
[16:44] <Tjoppen> I use vbindiff
[16:45] <natrixnatrix89> guys.. what purpose are you mostly using ffmpeg for?
[16:46] <natrixnatrix89> php?
[16:46] <natrixnatrix89> or just mostly converting files for own needs?
[16:47] <gearaholic> I use it for a mini youtube clone i made for a client,  as well as other video encoding needs 
[17:55] <fris> anyone got a url handy for cmd lines for encoding videos (quality and size) for web and mobile devices its for a video based site
[18:05] <natrixnatrix89> gearaholic: can I see the url?
[18:09] <linuxdev> Hi, does digest authentication for RTMP exists in FFmpeg ?
[18:41] <ttielu> Hey, I need to develop an application that can check if an RTMP stream is online and if so, take a picture of it. ffmpeg seems a good choice for this (confirm?). Are there any up-to-date Java mappings available that I can use for accomplishing this task?
[18:52] <DrSlony> Hey, which version of ffmpeg has the stabilizer/deshaker/whateveritscalled filter?
[18:52] <JuNiOx> hello guys, I have some videos.mkv (720p) which I'd like to reduce its size to 640x360. I have tried some basic commands with ffmpeg but the video quality is very poor. Does anyone know how to convert that? maybe to .avi or mp4 directly in order to keep the video quality?
[18:56] <DrSlony> JuNiOx 
[18:56] <JuNiOx> hello DrSlony 
[18:58] <DrSlony> ffmpeg -i /your/video.mkv -sws_flags lanczos -s 640x360 -vcodec libx264 -preset slow -crf 26 -threads 0 /out/file.mp4
[18:58] <DrSlony> 640x360 = ipod or something?
[18:58] <DrSlony> there is an ipod preset as well, or was, last time i checked
[18:59] <teratorn> hi, anyone have a clue why ffmpeg might be segfaulting (stacktrace included) ? http://bpaste.net/show/20375/
[19:01] <teratorn> (this is with GIT source as of today, btw)
[19:02] <JuNiOx> DrSlony: tks man, little different from that which I was trying... let me see this one,... actually it's not for ipod but the video will be streamed and that 720p version was consuming so much traffic
[19:05] <TiN> Hi all, how can I know with ffmpeg the bitrate of a file
[19:05] <TiN> ?
[19:05] <JuNiOx> ffmpeg -i file
[19:06] <pasteeater> or bitrate = file size/duration
[19:06] <DrSlony> JuNiOx try it on a small clip and see if youre happy with the file size and quality. For example try crf 30 and if it looks too shit on the device you will be viewing it in (dont judge on your computer if you will be watching it on a phone) then decrease 30 to 28 and try again, etc
[19:07] <pasteeater> DrSlony: ffmpeg from Git head has deshake. i don't think any of the releases do though.
[19:07] <JuNiOx> DrSlony: got it! will do... I'm just testing that previous one you told me.. just need to change from "-preset" to "-vpre" since it didnt find "-preset" option... is that ok?
[19:07] <TiN> JuNiOx: thanks, and if the file is a ts with multiple es?
[19:07] <DrSlony> pasteeater ah, ok, thanks. Would it be possible to use the deshake filter from git with 0.8.6?
[19:07] <DrSlony> JuNiOx old ffmpeg has -vpre, new ffmpeg has -preset
[19:08] <DrSlony> same thing afaik
[19:08] <JuNiOx> perfect!
[19:09] <pasteeater> similar, but different methods of applying the presets. -vpre used to old text file based preset emulation, while -preset accesses the presets directly via libx264
[19:09] <pasteeater> *used the
[19:09] <pasteeater> DrSlony: no, unless you don't mind messing with the code
[19:10] <pasteeater> or you can ask for deshake to be added to the next 0.8 release. you can ask that on the bug tracker as an enhancement/wish.
[19:45] <dericed> hi all, I need to force change a fourcc after ffmpeg runs (or during if possible). I need to use 'mpeg' for an mpeg2video track while ffmpeg uses m2v1. Any tools out there to find/replace a fourcc in a Quicktime?
[19:56] <DrSlony> pasteeater meh :]
[19:57] <DrSlony> did any of you manage to compile mplayer2 with ffmpeg-0.8.6?
[19:59] <vivienschilis> can anyone can help me with a ffprobe issue
[19:59] <vivienschilis> I even found the commit 
[20:04] <ttielu> Hey, I need to develop an application that can check if an RTMP stream is online and if so, take a picture of it. ffmpeg seems a good choice for this (confirm?). Are there any up-to-date Java mappings available that I can use for accomplishing this task? If not, best way to develop my own?
[20:07] <IchGucksLive> hi all im trying to  go from recordmydesktop to mp4 h264
[20:08] <IchGucksLive> input is a ogv 1280x720 output gives me only grey sound is ok 
[20:08] <IchGucksLive> ffmpeg -i test.ogv  -acodec libfaac -ab 128k -vcodec libx264 -vpre hq -crf 22 -threads 0 ziel.mp4
[20:09] <IchGucksLive> i found this line in a forum 
[20:16] <IchGucksLive> still no good output 
[20:26] <pasteeater> IchGucksLive: use a pastebin site to show your ffmpeg command and the complete terminal output
[20:27] <IchGucksLive> ok
[20:29] <IchGucksLive> pasteeater: http://paste.pocoo.org/show/511062/
[20:29] <IchGucksLive> ffmpeg -i test.ogv -ss 0  -t 20 -acodec libfaac -ab 128k -vcodec libx264 -vpre hq -s 1280x720 -crf 22 -threads 0 ziel.mp4
[20:30] <IchGucksLive> line 14 Stream #0.0: Invalid Codec type -1
[20:30] <IchGucksLive> this may be the reasen 
[20:31] <pasteeater> your ffmpeg is really old. outputs from recordmydesktop are odd, and your version doesn't include the fix that allows ffmpeg to decode them properly
[20:31] <pasteeater> http://ubuntuforums.org/showthread.php?t=786095
[20:31] <pasteeater> then you can do this:
[20:32] <pasteeater> ffmpeg -i test.ogv -t 20 -acodec libfaac -ab 128k -vcodec libx264 -preset slow -crf 22 output.mp4
[20:32] <IchGucksLive> first i need to go to the install procedure on the link ?
[20:33] <pasteeater> yes. or you can probably use mencoder if you don't want to compile ffmpeg. i recall mencoder from your ubuntu verision being able to decode that.
[20:33] <pasteeater> i don't know how to use mencoder though
[20:34] <IchGucksLive> i will compile ffmpeg 
[20:49] <mantas322> anyone here?
[20:49] <mantas322> HELLO!
[20:49] <mantas322> HELLO! >:O
[20:49] <mantas322> !?
[20:50] <JuNiOx> just type your doubt mantas322, in case anyone knows ... you'll get your help
[20:50] <mantas322> i want wondering if antyone had a similar problem whilst converting various video types into mp4
[20:50] <mantas322> where the result is GREEN
[20:50] <mantas322> the video is green and has a few artifact heer and there
[20:51] <mantas322> could this problem also be atributed to the original video not being "muxed" correctly?
[20:51] <mantas322> last week I converted 1678 various video to mp4
[20:51] <JuNiOx> which command line are you using?
[20:52] <mantas322> 433 of those ffmpeg gave me the bad "muxed" error
[20:52] <mantas322> 1 sec
[20:52] <mantas322> only arguements i was giving it is 1200 bitrate and -mp4
[20:53] <pasteeater> use a pastebin site to show your ffmpeg command and the complete terminal output
[20:53] <JuNiOx> guys, trying to convert from mp4 to avi using "ffmpeg -i $i.mp4 -vcodec copy -acodec copy $i.avi".... the file was generated fine but got no audio, any idea? got no error message
[20:53] <pasteeater> use a pastebin site to show your ffmpeg command and the complete terminal output
[20:54] <mantas322> pasteeater, thanks, but I dont have time for that sorry
[20:54] <pasteeater> then we can't help you
[20:54] <pasteeater> if you don't have the time to help yourself
[20:54] <mantas322> I was just thinkin maybe u can guess what the green thing is
[20:54] <pasteeater> might be your player
[20:54] <pasteeater> might be your input
[20:54] <IchGucksLive> pasteeater: ERROR: libx264 version must be >= 0.118.
[20:54] <pasteeater> might be your command
[20:54] <mantas322> seems like .02% of my converted videos are green
[20:55] <mantas322> thanks
[20:55] <pasteeater> IchGucksLive: what ubuntu version are you using?
[20:55] <IchGucksLive> 10.04
[20:55] <IchGucksLive> and i did the 10.04 install 
[20:55] <pasteeater> and you followed the guide word-for-word?
[20:55] <IchGucksLive> yes
[20:55] <IchGucksLive> the optional is not requierd or
[20:56] <IchGucksLive> i will pull x264 again 
[20:58] Action: pasteeater dusts off the old 10.04 VM...
[20:59] <pasteeater> lucid seems a bit snappier than oneiric. i'll blame unity.
[20:59] <ttielu> is there a way to configure the timeout when connecting to a stream using ffplay?
[21:01] <IchGucksLive> pasteeater: libx264 not found brrrr
[21:02] <IchGucksLive> what if i use medibuntu 
[21:02] <pasteeater> i don't think medibuntu will provide anything newer.
[21:02] <pasteeater> give me a few miuntes to test
[21:03] <ttielu> you can git compile x264, no?
[21:03] <pasteeater> yes
[21:03] <ttielu> http://ubuntuforums.org/showthread.php?t=786095 - is that the one you are following?
[21:03] <ttielu> cause, worked for me on ubuntu ..
[21:03] <pasteeater> i assume IchGucksLive is following http://ubuntuforums.org/showpost.php?p=9868359&postcount=1289
[21:04] <IchGucksLive> yes i start new with the last  comands first so remove all 
[21:08] <pasteeater> works for me. either your x264 didn't install correctly, and/or you have old x264 installed that is interfering.
[21:08] <IchGucksLive> im now on the x264
[21:20] <IchGucksLive> pasteeater:  past step 6
[21:22] <kakohari> Hi all, I am trying to extract single images from Videos. Sources are ffvhuff or dnxhd. When exporting images, it is not frame-accurate. Is this a known issue? I am pasting cli and stuff right now...
[21:24] <kakohari> This is what is coming out of ffmpeg: http://pastebin.com/BUsfVVzp
[21:25] <kakohari> I am having problems to parse "[image2 @ 0x23b5580] Could not get frame filename number 2 from pattern '/home/kai/Bilder/21_11_2011_lossless.bmp'" (probably update to brain 2.0 needed) :)
[21:26] <pasteeater> your command is missing, or i didn't see it
[21:26] <kakohari> f**k
[21:26] <IchGucksLive> pasteeater: i past now step 7
[21:27] <kakohari> ffmpeg -ss 00:00:05:00 -i /video/21_11_2011__12_45.avi -t 1 /home/kai/Bilder/21_11_2011_lossless.bmp > ~/Dokumente/ffmpeg_ffvhuff.txt 2>&1
[21:27] <kakohari> ouch, I am sorry
[21:27] <kakohari> Was meant to be pasted on pastebin
[21:27] <pasteeater> that's ok
[21:27] <pasteeater> change -t 1 to -vframes 1
[21:27] <pasteeater> as for frame accuract, move -ss as an output option
[21:28] <IchGucksLive> pasteeater:  i past now all steps what is this updating do i need this also 
[21:28] <pasteeater> no.
[21:29] <kakohari> pasteeater: so -ss has to be given after -i ?
[21:29] <IchGucksLive> so start now trying to get from ogv to mp4
[21:29] <pasteeater> kakohari: it doesn't have to be, but it changes the behavior of -ss
[21:29] <pasteeater> http://ffmpeg.org/pipermail/ffmpeg-user/2011-November/002976.html
[21:30] <pasteeater> also http://ffmpeg.org/pipermail/ffmpeg-user/2011-November/003221.html
[21:30] <IchGucksLive> pasteeater:  DONE B)
[21:31] <pasteeater> it worked?
[21:31] <pasteeater> ffplay output.mp4
[21:32] <IchGucksLive> the 20sec where great i will no go for the 9min 
[21:32] <IchGucksLive> also faster 32frames/sec
[21:32] <kakohari> pasteeater: thanks, thats summing it up
[21:34] <kakohari> Do I always have to set -threads on multicore-systems to make use of the cores?
[21:34] <pasteeater> for decoding? i don't know.
[21:34] <kakohari> And for encoding?
[21:34] <pasteeater> -threads 0 is default when encoding with libx264.
[21:34] <kakohari> I had terrible slow results while encoding to dnxhd wit h-mbd rd
[21:35] <kakohari> 2 fps on Core2Duo
[21:36] <pasteeater> ffmbc might be worth a try if you're working with dnxhd
[21:36] <pasteeater> http://code.google.com/p/ffmbc/
[21:37] <kakohari> Yes, I already tried it
[21:37] <kakohari> Same behavior
[21:41] <kakohari> Hmm, somehow confused right now. http://pastebin.com/qzwemQYC shows the command and output, but no image is created
[21:42] <kakohari> This .mov has been created with ffmpeg
[21:42] <kakohari> And is playing fine e.g. in vlcplayer
[21:44] <pasteeater> no "21_11_2011_vc3_schnell.bmp" was created?
[21:45] <pasteeater> the duration of the input is only 5 and you are trying to get an image at 5
[21:49] <kakohari> Tadaa! Classical stupid selfown -.-
[21:50] <pasteeater> ffmpeg should be more verbose about that. that's twice i've seen that in two or three days.
[21:50] <kakohari> hehe, thats embarrassing. But verbosity would be nice
[21:51] <kakohari> Shouldn't it work with 00:00:04:00 then?
[21:51] <kakohari> Yes, it does
[21:54] <pasteeater> or just "4"
[21:55] <kakohari> So a single number refers to full seconds?
[21:56] <pasteeater> yes
[21:57] <kakohari> Thanks, thats good to know
[22:41] <eldios> hey guys.. is it possible to use ffmpeg to capture a portion of the screen and create a fake webcam device out of it?
[22:41] <eldios> (I suppose a dummy/fake V4L device)
[22:46] <pasteeater> maybe this? http://allonlinux.free.fr/Projets/AVLD/
[22:47] <pasteeater> i didn't really look into it though
[22:57] <eldios> thanks pasteeater 
[22:58] <ttielu> Can anyone give me any advice about using ffmpeg inside Java?
[23:06] <muley> hey, so i'm getting an error "max_analyze_duration reached", and have found the analyzeduration option, but i cant find any docs on what this value actually does?
[23:06] <muley> can anybody point me in the right direction to some docs or help me understand plz?!
[23:07] <muley> it seems some people set "-analyzeduration 0" and some do "-analyzeduration 1000000000"
[23:08] <muley> some do "-analyzeduration 20M", but nobody eplains it :(
[23:09] <Mavrik> muley, it's how much video ffmpeg takes to analyize the contents (streams, codecs, bitrate, etc.)
[23:10] <muley> so it's the length to input of the input file, not processing time?
[23:10] <muley> alright so i guess that makes sense why i only get the error for 30min files and not short ones
[23:10] <muley> the option seems to be in seconds?
[23:11] <Mavrik> hmm, I can't find the parameter in documentation
[23:11] <Mavrik> which tool are you using?
[23:12] <pasteeater> 'ffmpeg -h' says microseconds
[23:12] <muley> tool? i'm converting an MP3 to FLV for streaming...
[23:12] <muley> ffmpeg -i '<INPUT PATH>' -f mp3 -acodec libmp3lame -vn -ar 22050 -ab 64k '<OUTPUT PATH>'
[23:12] <muley> er... not to flv
[23:13] <muley> just mp3
[23:13] <pasteeater> does it create a playable file regardless of the message?
[23:13] <muley> no
[23:13] <muley> it does when my input file is 128kbps, not 192kbps
[23:14] <pasteeater> use a pastebin site to show your ffmpeg command and the complete terminal output
[23:15] <muley> k
[23:18] <muley> http://pastie.org/2900304
[23:19] <pasteeater> the important message is: [mp3 @ 0x802e0db10] Header missing
[23:20] <muley> i re-saved the input mp3 file at 128kbps to test and it didnt error. the original input was 192kbps
[23:20] <muley> ah..
[23:20] <muley> so the timeout may not even matter?
[23:21] <muley> the variable bitrate/file must be the issue then
[23:22] <muley> thanks for the info.. guess i was looking in the wrong place
[23:30] <teratorn> if anyone wants to have a look at this crash, it would be greatly appreciated https://ffmpeg.org/trac/ffmpeg/ticket/675 :)
[00:00] --- Tue Nov 22 2011

More information about the Ffmpeg-devel-irc mailing list