[Ffmpeg-devel] ogg vorbis encode?

Justin Ruggles jruggle
Sun Aug 14 02:38:07 CEST 2005

Rich Felker wrote:
> On Sat, Aug 13, 2005 at 05:53:58PM +0200, Michael Niedermayer wrote:
>>On Sat, Aug 13, 2005 at 10:03:00AM -0400, Rich Felker wrote:
>>>On Sat, Aug 13, 2005 at 09:23:00AM -0400, Justin Ruggles wrote:
>>>>I guess that means the problem might be
>>>>in the ogg muxer?  Even doing '-acodec copy' on a valid ogg results in
>>>>an invalid ogg.
>>>Probably so. Ogg has very stupid codec header storage, and the muxer
>>>probably doesn't store the headers.. :(
>>vorbis in ogg encoding did work fine in the past, but indeed it seems broken
>>currently, i dont know why
> It's because the encoder was fixed to output its headers as extradata
> rather than (incorrectly) as audio frames, but the ogg muxer has not
> been fixed to convert them back to packets for the broken ogg header
> format.. At least that's my guess.

I did look into that.  The header stuff does seem a bit off.  There are
other issues as well though.  The vorbis encoder seems to be writing
data to the ogg stream during encoding, but the ogg packets aren't
written until the end of stream (or 'q' pressed).  I'll look into this
some more to see what might be wrong specifically.  I thought ogg pages
were only supposed to be around 64k max.  Why would it wait until the
end to write them all?  Hmm. Time for some fun debugging or maybe an
ffmpeg native ogg muxer to compliment the recently added native demuxer.
 It would be great to be able to multiplex ogg vorbis and ogg theora
with ffmpeg.


More information about the ffmpeg-devel mailing list