[Ffmpeg-devel] Re: [PATCH] Compilation fixes part 1

Michael Niedermayer michaelni
Fri Aug 26 17:33:49 CEST 2005


On Fri, Aug 26, 2005 at 01:55:53PM +0000, Burkhard Plaum wrote:
> > > +int _a52_syncinfo( AVCodecContext * avctx, uint8_t * buf, int * flags, int
> * sample_rate, int * bit_rate )
> > 
> > names starting with _ are reserved in ansi/iso c IIRC
> What would be better? av_a52_syncinfo?

rather ff_ i think
the difference (i dont know how much or little of ffmpeg actually conforms)
is that ff_ should be internal stuff
avcodec_ public stuff specific to libavcodec
av_ stuff specific to libavformat (it was named libav long time ago) or
generic stuff which needs a short name due to common use like av_log()


More information about the ffmpeg-devel mailing list