[Ffmpeg-devel] No more warning message for incorrect image filename syntax

Eran Guendelman erang
Mon May 9 21:13:05 CEST 2005

I installed ffmpeg 0.4.9-pre1 from a SuSE rpm (specifically 
ffmpeg-0.4.9-3.pm.pre1.i686.rpm).  I tried grabbing a frame from a video, 
and used e.g. "t.jpg" as my output filename.  Rather than telling me 
that the filename required a %d, I got back the error message 

Unable for find a suitable output format for 't.jpg'

Since I initially couldn't tell that the problem was with my filename, I
spent some time trying to figure out what was wrong, trying all sorts of
other file formats, re-installing, etc.  (Actually yuv and gif seemed to
work, but those formats weren't useful to me).

Eventually I tried an older rpm I had lying around: 
ffmpeg-0.4.6-fr3.i386.rpm, and when I ran this with the same commandline 
arguments it gave me the more reasonable message

t.jpg: Incorrect image filename syntax.
Use '%d' to specify the image number:
  for img1.jpg, img2.jpg, ..., use 'img%d.jpg';
  for img001.jpg, img002.jpg, ..., use 'img%03d.jpg'.

So I'm not sure if the absence of this message from the latest version is 
due to changes in the source code, or somehow due to whoever packaged this 
rpm.  But I hope this message can be put back so others don't run into the 
same confusion.

I'm not subscribed to this list so reply to erang at stanford.edu

More information about the ffmpeg-devel mailing list