[Ffmpeg-devel] ffmpeg crashes on windows

Anders Nilsson breakin.outbreak
Sun May 15 17:31:56 CEST 2005

I'm sure. Got new CVS-version, deleted all avformat/codec.dll/lib and
tested again. Same error. Tried both with the DLL-files from
cvs/avformat, cvs/avcodec and those that are installed in C:\Program
Files\ffmpeg. I use the header-files that are installed in C:\Program
Files. And ffmpeg.exe still causes Acces violation even though the
dll-files installed by 'make install' is in that very directory (ie
cannot be wrong). Could it be my mingw? Or my .NET-stuff used for
making shared libraries? All function calls works uptil avcodec_open
btw (in output_example). It doesn't crash, just doesn't find any

Remember everything worked perfect to some cvs-versions ago (could be
dll-mixing but at least I got it working before).

Are there any other newbie win32-problems with compiling ffmpeg? If
it's OT feel ok to mail me outside of the list. I guess I could step
through the code in the dll if I did a debug build of it. That's a
good idea for someone unfamiliar with the ffmpeg-source?

Anders Nilsson

More information about the ffmpeg-devel mailing list