[Ffmpeg-devel] MPEG2 seeking broken

Ulrich von Zadow coder
Tue Aug 1 18:30:08 CEST 2006

Diego Biurrun wrote:
> On Tue, Aug 01, 2006 at 05:21:44PM +0200, Ulrich von Zadow wrote:
>> Diego Biurrun wrote:
>>> On Fri, Jul 28, 2006 at 04:38:52PM +0200, Ulrich von Zadow wrote:
>>>> Ulrich von Zadow wrote:
>>>>> I've managed to reproduce the error with a version of ffplay modified as 
>>>>> per the attached patch. The modified version seeks using the video 
>>>>> stream. For xvids, this works perfectly, for mpeg2s, it produces garbled 
>>>>> images and the error messages that you've already seen.
>>>> In an attempt to maybe get notification if someone fixes the bug, I've 
>>>> opened a bug report in bugzilla.
>>>> Is it ok to upload the 200k test movie there?
>>> Yes.
>> Done.
>> I still have the feeling I'm sending my messages into a black box. Is 
>> anyone fixing this stuff? I've found more bugs (for instance, realvideo 
>> seeking seems broken as well in some cases) and I'd really like to help 
>> ffmpeg stability, but this really requires more cooperation than terse 
>> one-line messages and ffmpeg developers disagreeing on the proper way to 
>> send in bug reports.
> Getting developers interested is not always easy...

Yes, I've figured that out.

So let me put it another way: I'm looking for someone I can work with to 
fix ffmpeg bugs and generally make this library more stable. I can work 
as a bug reporter and I'll make every effort to give you reproducible 
bug reports, but I lack the knowledge of ffmpeg internals that is 
nessesary to fix them. Any takers?

By the way, the mpeg seeking bug we're talking about has been in the 
library since at least December 2006 and that tells me there's probably 
lots more to be found.

> As for proper RealMedia support, we're all waiting for Roberto to sit
> down and rewrite the RM demuxer in libavformat ...

How about writing a warning message to the console when features that 
are known to be unfinished are used?

I see that ffmpeg has regression tests. They seem to cover en- and 
decoding but not seeks - would it be easy to add that?



More information about the ffmpeg-devel mailing list