[Ffmpeg-devel] BUG: x264 and pthreads

Justin Ruggles jruggle
Sat Aug 5 21:36:37 CEST 2006

Joshua Boyd wrote:
> FFmpeg requires pthreads when using x264.  --enable-x264 alone fails,
> but --enable-x264 and --enable-pthreads works.
> The first way, ./configure says:
> ERROR: x264 not found
> and config.err contains:
> gcc -c -o /tmp/ffmpeg-conf-1528-30906-27017.o
> /tmp/ffmpeg-conf-6644-30906-19992.
> c
> gcc -Wl,--warn-common -o /tmp/ffmpeg-conf-10696-30906-32630
> /tmp/ffmpeg-conf-152
> 8-30906-27017.o -lm -lz -ldts -lgsm -lvorbis -lvorbisenc -logg -logg
> -lx264
> /usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libx264.a(encoder.o):
> In funct
> ion `x264_encoder_encode': undefined reference to `pthread_create'
> /usr/lib/gcc/i486-linux-gnu/4.0.3/../../../../lib/libx264.a(encoder.o):
> In funct
> ion `x264_encoder_encode': undefined reference to `pthread_join'
> collect2: ld returned 1 exit status
> ERROR: x264 not found
> I found this on ubuntu 6.06 (which uses a Febuary cvs version of x264)
> and a fresh checkout from svn of ffmpeg.  This is different from
> Monday's issue with x264.  Yesterday, someone on ffmpeg-users complained
> of the same issue (he didn't say what version of x264 or linux
> distribution he was using).
> It seems to me that the ./configure script just needs to know of the
> dependence like the way is says that libogg must be included to use
> libvorbis. 
> I've never dug into the configure script, so I'm just posting a bug
> report for now.  Maybe I will come up with a patch as well.

I ran into this problem as well. x264 can be compiled with or without
pthreads. If you use x264 in FFmpeg, pthread usage has to match your
x264 build.


More information about the ffmpeg-devel mailing list