[Ffmpeg-devel] make test fails for flac

Martin von Gagern Martin.vGagern
Thu Aug 10 00:07:33 CEST 2006

Luca Abeni wrote:
> I do not get this error... I just checked, and compression_level is a
> valid option (see libavcodec/utils.c). I see that you are using shared
> libraries... Maybe ffmpeg_g ended up loading the wrong .so files (maybe
> you have an older version installed somewhere)?

Indeed, the tests were dynamically linked against libs from the
0.4.9_p20060530 Gentoo ebuild. Setting LD_LIBRARY_PATH solved the issue.

Should I have a look at the build process, see if this can be automated?
Because the same situation could lead to false negatives as well, a
successful regression test while the latest build would cause errors.

Now I'm running into the test error you already reported yesterday, with
the same checksums.

Greetings, and thanks for your swift response,

More information about the ffmpeg-devel mailing list