[Ffmpeg-devel] Swscaler regression test failure

Luca Abeni lucabe72
Fri Aug 11 14:19:59 CEST 2006


first of all, thanks for testing swscaler in ffmpeg!

On Fri, 2006-08-11 at 13:45 +0200, Panagiotis Issaris wrote:
> Hi,
> When configuring FFmpeg using --enable-gpl and --enable-swscaler make test fails.
> takis at issaris:/usr/local/src/ffmpeg/tests$ ../ffmpeg_g -y -flags +bitexact -dct fastint -idct simple -y -qscale 10 -f pgmyuv -i vsynth1/%02d.pgm -an -vcodec mjpeg -pix_fmt yuvj420p ./data/a-mjpeg.avi
> FFmpeg version SVN-r5982, Copyright (c) 2000-2004 Fabrice Bellard
>   configuration:  --enable-gpl --enable-swscaler
>   libavutil version: 49.0.0
>   libavcodec version: 51.11.0
>   libavformat version: 50.5.0
>   built on Aug 11 2006 13:07:30, gcc: 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
> Input #0, image2, from 'vsynth1/%02d.pgm':
>   Duration: 00:00:02.0, start: 0.000000, bitrate: N/A
>   Stream #0.0: Video: pgmyuv, yuv420p, 352x288, 25.00 fps(r)
> swScaler: 0x0 ( is not supported as output format
> Cannot get resampling context
Yes, this is a known issue: unfortunately, if you enable swscale some
tests fail. This particular failure is due to the fact that the yuvj420p
pixel format is not supported by swscale.

There currently are 2 unsupported formats: yuvj420p and monow.
I am working on fixing this, but unfortunately I am very busy with other
things, so my development is slower than I expected.

Copy this in your signature, if you think it is important:
                               N O    W A R ! ! !

More information about the ffmpeg-devel mailing list