[Ffmpeg-devel] [MacIntel] Testers welcome!

herve.flores herve.flores
Sat Aug 12 20:02:34 CEST 2006

Le 12 ao?t 06 ? 18:42, Guillaume POIRIER a ?crit :

> Hello folks,
> The last part of patches to add MacIntel support has been committed.
> Could the ppl who have access to any of these machines confirm that  
> it works?
> If so, I'll update changelog to advertise it.
> Guillaume

test on PPC (cross-compile) with a fresh SVN and no patch add, MacOS  
10.4.7 with gcc 3.3 and gcc 4.01 (I don't know exactly wich ones is  

I have the same result that with an older patch to enable -mmx = can  
compile (and  preceding tests worked great ! :-)

for info:

cag06-1-82-234-130-166:~/ffmpeg/ffmpeg herve$ ./configure --cross- 
compile --cpu=x86 --extra-cflags='-arch i386 -isysroot /Developer/ 
SDKs/MacOSX10.4u.sdk' --extra-ldflags='-isysroot /Developer/SDKs/ 
MacOSX10.4u.sdk -arch i386 -L/Users/herve/ffmpeg/INTEL/lib/' --extra- 
cflags='-I/Users/herve/ffmpeg/INTEL/include/' --enable-pp --enable- 
gpl --enable-pthreads --enable-static --disable-shared --enable-a52 -- 
enable-amr_nb --enable-amr_wb --enable-amr_if2 --enable-x264
install prefix   /usr/local
source path      /Users/herve/ffmpeg/ffmpeg
C compiler       cc
make             make
CPU              x86 (generic)
big-endian       no
inttypes.h       yes
broken inttypes.h no
MMX enabled      yes
Vector Builtins  yes
3DNow! Builtins  yes
gprof enabled    no
zlib enabled     yes
libgsm enabled   no
mp3lame enabled  no
libogg enabled   no
Vorbis enabled   no
FAAD enabled     no
faadbin enabled  no
FAAC enabled     no
XviD enabled     no
x264 enabled     yes
a52 support      yes
a52 dlopened     no
DTS support      no
pp support       yes
Software Scaler enabled no
debug symbols    yes
strip symbols    yes
optimize         yes
static           yes
shared           no
video hooking    yes
SDL support      no
Imlib2 support   no
FreeType support no
Sun medialib support no
pthreads support yes
AMR-NB float support yes
AMR-NB fixed support no
AMR-WB float support yes
AMR-WB IF2 support yes
network support      yes
IPv6 support         yes
.align is power-of-two yes
License: GPL
Creating config.mak and config.h...

AMR WB FLOAT NOTICE ! Make sure you have downloaded TS26.204
V5.1.0 from
and extracted the source to libavcodec/amrwb_float

AMR NB FLOAT NOTICE ! Make sure you have downloaded TS26.104
REL-5 V5.1.0 from
and extracted the source to libavcodec/amr_float
If you try this on alpha, you may need to change Word32 to int in amr/ 

and make ok (and sudo make install too)

I cannot test the binary because I'm on ppc (I will send it to a  
friend to test it, if it doesn't work I'll write a new mail ;-))


PS: just a question, it's normal that I always have these warnings  
since a few weeks? (with a ppc compile or a cross-compile)
i686-apple-darwin8-gcc-4.0.1: unrecognized option '-pthread'
(exactly 274 occurences found during compile)
REM: my configure has "--enable-pthreads" (with a "s")



More information about the ffmpeg-devel mailing list