[Ffmpeg-devel] swscale and regression tests

Luca Abeni lucabe72
Mon Aug 14 11:43:37 CEST 2006

Hi all,

as someone already noticed, if ffmpeg is configured with
"--enable-swscaler --enable-gpl", then "make test" fails. I investigated
this problem, and I am trying to find a solution.

A first problem is that some ffmpeg's pixel formats are not supported by
swscale. This causes, for example, failures on the jpeg, mjpeg, and
similar tests.

When I manually disable the tests involving unsupported formats, some
tests still fail. I checked them, and it turned out that all the failing
tests involve rescaling (for example the dv tests) or pixel format
Double thinking about it, I arrived to the conclusion that these
failures have to be expected, because swscale uses different algorithms
respect to libavcodec's scaling and format conversion routines... So,
the results can be different. Is this understanding correct? (I mean:
video rescaling and format conversion are approximated operations,

So, how to fix "make test" with swscale? I can think about 2 possible
solutions, but there are probably more:
1) leave the libavocodec scaling and format conversion routines in
place, and always use them in the tests (even if swscale is enabled)
2) use different *.ref files whe swscale is enabled

What are people's opinions / ideas / suggestions about this?

Copy this in your signature, if you think it is important:
                               N O    W A R ! ! !

More information about the ffmpeg-devel mailing list