[Ffmpeg-devel] [PATCH] AVISynth support

Steve Lhomme slhomme
Thu Aug 17 14:34:01 CEST 2006

Herv? W. wrote:
> Hi Steve,
> On 17/08/06, Steve Lhomme wrote:
>> $ /bin/sh.exe --version
>> GNU bash, version 2.04.0(1)-release (i686-pc-msys)
>> Copyright 1999 Free Software Foundation, Inc.
>> If I change the script to try sh it gives the error "No compatible shell
>> script interpreter found.". So I guess the bash shell in MSys is not
>> compatible ?
> I think you'll need bash 2.05b (available on the mingw website). If
> you have any further problems, have a look at
> http://arrozcru.no-ip.org/ffmpeg_wiki/tiki-index.php
> In particular:
> http://arrozcru.no-ip.org/ffmpeg_wiki/tiki-index.php?page=MSys_MinGW

Indeed, it works better when installing bash 2.05 from an old snapshot. 
Too bad it's not installed by default with MSys... Now -lvfw32 is added 
to EXTRALIBS correctly.


More information about the ffmpeg-devel mailing list