[Ffmpeg-devel] [MacIntel] Testers welcome!

herve.flores herve.flores
Fri Aug 18 19:40:50 CEST 2006

Le 13 ao?t 06 ? 11:52, Diego Biurrun a ?crit :

> On Sun, Aug 13, 2006 at 11:27:04AM +0200, Ulrich von Zadow wrote:
>> Diego Biurrun wrote:
>>> On Sat, Aug 12, 2006 at 08:29:34PM +0200, Ulrich von Zadow wrote:
>>>> Guillaume POIRIER wrote:
>>>>> The last part of patches to add MacIntel support has been  
>>>>> committed.
>>>>> Could the ppl who have access to any of these machines confirm  
>>>>> that it
>>>>> works?
>>>> Works here using plain ./configure and ./configure --disable-shared
>>>> --disable-debug --disable-encoders.
>>>> It is still nessesary to run ranlib on the static libraries  
>>>> after make
>>>> install, though, so make install is missing a step.
>>> Hmmm?  ranlib is run on the static libraries, look at the rule in  
>>> the
>>> Makefile that creates them:
>>> $(LIB): $(STATIC_OBJS)
>>>        rm -f $@
>>>        $(AR) rc $@ $^ $(EXTRAOBJS)
>>>        $(RANLIB) $@
>> The error is '../lib/libavformat.a is out of date; rerun ranlib(1)
>> (can't load from it)'. Running ranlib after install solves the issue.
>> This is Mac-specific.
> Please try the attached patch, if you can test it on PPC as well as
> Intel that would be a plus.
> Diego
> <install_extra_cmd.diff>

sorry for the not speed feedback (I'm on PPC MacOSX10.4.7, new gcc  
4.01, etc = the last Apple's system)
my hardware is a G4 (uname -p =>  powerpc)

I DL a fresh SVN.
If I'm not wrong, seems that the patch is already applied, no?
I tried to apply it and :

cag06-1-82-234-130-166:~/ffmpeg/ffmpeg herve$ patch -p0 < /Users/ 
patching file configure
Hunk #1 FAILED at 580.
Hunk #2 succeeded at 1767 with fuzz 2 (offset 5 lines).
1 out of 2 hunks FAILED -- saving rejects to file configure.rej
patching file common.mak
Reversed (or previously applied) patch detected!  Assume -R? [n] n
Apply anyway? [n] n
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file common.mak.rej

I tried to compile with my usually configure:
cd ffmpeg
make clean
make distclean
./configure --enable-pp --enable-gpl --enable-pthreads --enable- 
static --disable-shared --enable-a52 --enable-amr_nb --enable-amr_wb  
--enable-amr_if2 --enable-x264 --enable-xvid --enable-mp3lame  -- 
enable-libogg --enable-libgsm --enable-dts --enable-faac --enable- 
faad --enable-vorbis

all is OK :-)



More information about the ffmpeg-devel mailing list