[Ffmpeg-devel] img_convert crashes

Mohnhaupt, Denis Denis.Mohnhaupt
Tue Aug 22 14:38:44 CEST 2006

Hi everyone,


I am new to ffmpeg, so I followed the steps in the documentation, used the sample code from Martin B?hme and changed it so that my decoded video frame is rendered into an openGL texture (the FrameRGB is copied once more into the texture buffer) which is then displayed. All of this apparently works.


But then I discovered that it only worked with my initial test video which was mpg2, but crashes with other videos I tried which were mpg1 and mpg4. All of these had to be converted from PIX_FMT_YUV420P to PIX_FMT_RGB24 according to their properties and the crash occurs after calling img_convert(). If I display the original video frame in YUV it looks ok from what I can tell. I am new to MinGW as well and do not know how to use a debugger with that environment if this would help at all, because unfortunately when I had a look at the source code of the img_convert function I was far from understanding it sufficiently ;-)


Is this a known issue or might I have done something wrong? I checked the developer mailing list for nearly all of 2006 but couldn't find a matching topic. Also I have the latest version of ffmpg, which I checked out this morning (the last version I tried was about 1 week old, the problem occurred there as well).


Furthermore I noticed heavy artifacts in the working video which do not happen when I watch this video with another player like Windows Media Player. What could be the cause of this?


Also I'd like to know if there is a public list of known bugs and issues. I couldn't find anything like this.


Thanks in advance


More information about the ffmpeg-devel mailing list