[Ffmpeg-devel] Re: [BUG] mpegaudiodec.c is broken since revision 6098

Michael Niedermayer michaelni
Mon Aug 28 00:04:49 CEST 2006


On Mon, Aug 28, 2006 at 12:47:00AM +0300, Uoti Urpala wrote:
> On Sun, 2006-08-27 at 23:30 +0200, Michael Niedermayer wrote:
> > On Sun, Aug 27, 2006 at 01:29:44PM +0000, Sebastian Freundt wrote:
> > > >> Using -ac ffmp3 in mplayer for playing low bitrate mp3 files results in lots
> > > >> of error messages and corrupted sound:
> > > >> overread, skip 29 A-V:  0.980 ct:  0.305 598/598  1%  0%  1.6% 0 0
> > not reproduceable with any mp3 i have tried, so i need a sample
> > file which shows this behavior (=corrupted sound not just some error
> > messages)
> The error messages look like he's using MPlayer with a file that has
> video too.

indeed, i should look more closely at bugreports ...

> Didn't you remove direct support for non-packetized bitstream


> (log message looked like that, I didn't look more closely)? Maybe he's
> playing a VBR avi where the avi audio packets do not correspond to mp3
> packets or something similar.

the problem is though the error messages dont look like the packetization
feeded into the decoder was wrong (i would expect more errors in that case),
it rather looks like the bitstream itself is wrong, i do have a few of these
too but none sounded corrupted. to make it more tricky, i think my code is 
"buggy" for the case that the overread happens during a buffer switch but
id like to have a sample for testing ...


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

In the past you could go to a library and read, borrow or copy any book
Today you'd get arrested for mere telling someone where the library is

More information about the ffmpeg-devel mailing list