[Ffmpeg-devel] [PATCH] Vorbis without libogg in the configure script

angustia at arrozcru.no-ip.org angustia
Thu Aug 31 18:59:32 CEST 2006


When --enable-vorbis is passed without --enable-libogg, we get the warning
"libogg must be enabled to enable Vorbis.", fail is set to "yes", vorbis
is set to "no", and the configure script goes on.

This fails correctly:
./configure --enable-memalign-hack --enable-vorbis

This shows the error message but goes on to configure without vorbis:
./configure --enable-memalign-hack --enable-vorbis --enable-gpl

The test for "$fail" = "yes" is inside the block test "$gpl" != "yes", so
"fail" only fails if --enable-gpl is not set.

Attached patch puts the test for "fail" outside the gpl tests... Should we
also remove the line 'vorbis="no"' (line 934), since fail is already set

Ramiro Polla
-------------- next part --------------
A non-text attachment was scrubbed...
Name: configure_libogg.patch
Type: application/octet-stream
Size: 417 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20060831/3d3a72fb/attachment.obj>

More information about the ffmpeg-devel mailing list