[Ffmpeg-devel] Still Trying to Compile on Mac OS X

Måns Rullgård mru
Sun Jul 2 12:47:51 CEST 2006

"Anthony N. Frasso" <afrasso at yahoo.com> writes:

> I think I'm on what... round 6? :-P
> Well, I hadn't tried compiling in a couple of weeks,
> so I thought I'd try again.  I redownloaded the source
> code and tried to compile... but that didn't work.  It
> seems the configure script can't find Xvid.  Just to
> make sure, I reinstalled Xvid, but I still get the
> same problem.
> cc -no-cpp-precomp -pipe -fomit-frame-pointer -force_cpusubtype_ALL -Wno-sign-compare -faltivec -Wl,-dynamic,-search_paths_first -o /tmp/ffmpeg-conf-24670-7632-15687 /tmp/ffmpeg-conf-7835-7632-25479.c -lz -lmp3lame -lxvidcore
> ld: table of contents for archive: /usr/local/lib//libxvidcore.a is out of date; rerun ranlib(1) (can't load from it)
> ERROR: XviD not found

Looks like Guillaume was right.  Run ranlib /usr/local/lib/libxvidcore.a.

M?ns Rullg?rd
mru at inprovide.com

More information about the ffmpeg-devel mailing list