[Ffmpeg-devel] Image formats missing?

Colin Dunlop colin
Mon Jul 17 16:27:37 CEST 2006


I'm trying to turn a bunch of jpegs into an AVI movie.

I've compiled the latest svn ffmpeg on Windows following the
guidelines of generating a Visual C++ compatible version:
I'm using MINGW and MSYS latest versions and all compiled ok.

However aside from the already discussed .dll.xxx versioning
problems, there appears to be only GIF support in ffmpeg. I
noticed that the code for the image formats is commented
out in "libavformat/allformats.h and .cxx" by a #if 0 block.

I read most of the docs and faq and compatibility notes
but don't see anything about how I get sgi, png, jpeg, or
tiff support added to the "configure" script anywhere - and
beside it looks like the current #if 0 block will stop this

Thanks for any pointers. I have versions of jpeg, png, libz
and tiff compiled up separately.




WindowsXP SP2 x86
MINGW latest
MSYS latest (with MSVS 2003 vcvars.bat addition)
MSVS 2003 (7.1)

Just try single file to test for now.

$ ffmpeg.exe -i ./vw.jpg -vcodec msmpeg4v2 ./out.avi
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
  configuration:  --enable-shared --disable-static --enable-memalign-hack 
  libavutil version: 49.0.0
  libavcodec version: 51.10.0
  libavformat version: 50.5.0
  built on Jul 17 2006 11:48:34, gcc: 3.4.2 (mingw-special)
./vw.jpg: Unknown format

$ ffmpeg -formats

Image formats (filename extensions, if any, follow):
 DE gif    gif


More information about the ffmpeg-devel mailing list