[Ffmpeg-devel] Header installation seems to be broken in SVNHEAD

Luca Abeni lucabe72
Wed Jul 19 12:19:04 CEST 2006

Hi all,

On Wed, 2006-07-19 at 12:07 +0200, Reimar Doeffinger wrote:
> Hello,
> On Wed, Jul 19, 2006 at 10:30:57AM +0100, M?ns Rullg?rd wrote:
> > ?smail D?nmez said:
> > > /usr/include/ffmpeg/avutil.h:29:17: log.h: No such file or directory
> Not my fault. ;-)
Sorry, I think that's my fault. I'll fix it in a short time.
I see 2 possibilities:
1) install log.h
2) move the "#include log.h" from common.h to internal.h

Which one is preferred?

> bswap.h is included unconditionally by common.h, which might have been a
> bad choice since it overwrites stuff from byteswap.h.
> But I find that very hard to decide because I don't know of any application
> except ffmpeg and my specially-ugly-hacked MPlayer using libavutil so far.
> Attached patch would be one simple way to fix it.
> Installing it _might_ be a good idea anyway, since it is duplicate code
> from MPlayer, and that might be way to get rid of that (though as I
> mentioned in another thread I'm having problems combining libswscale and
> libavutil, due to libswscale being compiled with -DHAVE_AV_CONFIG_H but
> not using av_malloc etc.).
I am working on fixing this. I already have a patch converting
libswscale to use av_log, av_malloc, and av_free (now that they all are
in libavutil). I'll probably send it tomorrow.

Copy this in your signature, if you think it is important:
                               N O    W A R ! ! !

More information about the ffmpeg-devel mailing list