[Ffmpeg-devel] Re: Matroska Conversion Errors

Ewan Grantham ewan.grantham
Thu Jul 20 22:42:06 CEST 2006

Well, I installed SVN and the development files for several object
files, and did a build out of the SVN checkout I did this morning. I'm
getting the same error. So evidently a "more recent" version of ffmpeg
is not the answer.

Anyone who can tell me what I SHOULD do to fix this?

On 7/20/06, Ewan Grantham <ewan.grantham at gmail.com> wrote:
> Am currently using the version of FFMPeg that is packaged for Ubuntu
> 6.06 (ffmpeg Version CVS, build 3276800). I am trying to convert a
> .MKV (matroska) file to an MPEG-2 file so I can play it back on my
> home Tivo.
> Running the conversion, I see a number of errors like the following:
> Error while decoding stream #0.0
> [matroska @ 0x82c8200]FIXME: implement support for BlockDurations
> [matroska @ 0x82c8200]FIXME: implement support for BlockDuration
> [mpeg4  @ 0x82c8200]header damaged
> Do I need a more recent version of ffmpeg? Or is there something wrong
> with the following command line when decoding an MKV:
> ffmpeg -i "Episode_01.mkv" -target ntsc-dvd -acodec mp2 -ab 192 -ac 2
> -ar 48000 -b 4096 -r 29.97 -s 720x480 -vcodec mpeg2video "Episode
> 01.mpg"
> TIA,
> Ewan

More information about the ffmpeg-devel mailing list