[Ffmpeg-devel] Re: Configure with msys/mingw

Christian Jacquemin Christian.Jacquemin
Mon Jul 24 19:19:27 CEST 2006

Diego Biurrun wrote:

> > I have upgraded to the HEAD revision of ffmpeg, but I still get
> > the same error with sh or with bash 2.05b... The revision says
> > that unnecessary darwin variable has been removed.
> Provide some more details like exact configure invocation and
> config.mak/config.err (don't attach them, they are too big).

Thank you very much Diego for your help.

Here are the additional details that might help you
to understand better the problem:

Configure invocation (both produce the same error):

bash ./configure --disable-static --enable-shared --enable-mingw32 --prefix=/usr
./configure --disable-static --enable-shared --enable-mingw32 --prefix=/usr


Error message in console (error comes from linking ld.exe (see
the last lines of the config.err file below)):

gcc is unable to create an executable file.
If gcc is a cross-compiler, use the --cross-compile option.
C compiler test failed.
If you think configure made a mistake, make sure you are using the latest
version from SVN.  If the latest version fails, report the problem to the
ffmpeg-devel at mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.


ld --version
GNU ld version 2.13.90 20030111

sh --version
GNU bash, version 2.04.0(1)-release (i686-pc-msys)

bash --version
GNU bash, version 2.05b.0(1)-release (i686-pc-msys)

gcc --version
gcc.exe (GCC) 3.2.3 (mingw special 20030504-1)


config.mak is not generated - The error occurs at the check_cc
step before config.mak generation.


More details about config.err: first lines about the environment
and last lines about error report:

# ./configure --disable-static --enable-shared --enable-mingw32 --prefix=/usr
ALLUSERSPROFILE='C:\Documents and Settings\All Users'
APPDATA='C:\Documents and Settings\mr\Application Data'
BASH_VERSINFO=([0]="2" [1]="05b" [2]="0" [3]="1" [4]="release"


BEGIN /tmp/ffmpeg-conf-3482-3220-24845.c
     1	int main(){
     2	    return 0;
     3	}
END /tmp/ffmpeg-conf-3482-3220-24845.c
gcc -c -o /tmp/ffmpeg-conf-28547-3220-6632.o /tmp/ffmpeg-conf-3482-3220-24845.c
-o /tmp/ffmpeg-conf-20963-3220-29335 /tmp/ffmpeg-conf-28547-3220-6632.o -lm
c:\mingw\bin\..\lib\gcc-lib\mingw32\3.2.3\..\..\..\..\mingw32\bin\ld.exe: Can't
open output def file $(@:.dll=.def)
C compiler test failed.

More information about the ffmpeg-devel mailing list