[Ffmpeg-devel] ffmpeg could not grab from video device whileis not open xawtv

Luca Abeni lucabe72
Tue Jun 6 09:29:21 CEST 2006

Hi Martin,

On Mon, 2006-06-05 at 12:52 +0200, Martin Farnik wrote:
> ffmpeg -vd /dev/video0 -an -s 720x576 -f mpeg -tvstd PAL -b 1024 -y
> ./test.mpg
> i will get:
> FFmpeg version CVS, Copyright (c) 2000-2004 Fabrice Bellard
>   configuration:  
>   libavutil version: 49.0.0
>   libavcodec version: 51.9.0
>   libavformat version: 50.4.0
>   built on May 31 2006 11:49:22, gcc: 3.4.1 (Mandrakelinux (Alpha 3.4.1-3mdk)
> [video4linux @ 0x82d1184]Fatal: grab device does not support suitable format
> Could not find video grab device
I just tried, and it worked here with an Osprey 100 card...
Anyway, if it does not work with your card can you try reverting this

If it works with the patch reversed, let me know and I'll try to fix the

However, you should really try using video4linux2 instead of
video4linux... Doesn't libavformat/v4l2.c compile on your system?

Proud to be "coglione"

More information about the ffmpeg-devel mailing list