[Ffmpeg-devel] FLV files have no sound

Guillaume POIRIER poirierg
Fri Mar 3 12:45:56 CET 2006


On 3/3/06, Alexander Mitev <alexmi at abv.bg> wrote:
> Hello again!
> I've
> submitted a problem to this forum about a week ago about the missing sound in FLV files, to which you didn't reply:
>  http://mplayerhq.hu/pipermail/ffmpeg-devel/2006-February/008094.html
> I see there are other people having the same problem to which you didn't reply either, whilst you reply to most of the others.
> So, as far as I can figure it out, there is a problem with ffmpeg that you
> just don't want to talk about or discuss.

Did you sign up for premium customer service? If not, you should
consider signing up to get premium answers to your questions, as you
seem to expect the community to.

> So, please be honest enough to at lest confess there is a real
> problem, or I will consider
> it unsolveable

Some of the support for proprietary formats like FLV and others are in
the early stages of being usable. If you happen to be in need of such
"half-finished reversed-engineered formats", it's just too bad for
you, and too bad for everyone. It means that we need more coders and

> if you keep quiet about it and will have to
> use another library.

That's the beauty of Open source and having multiple projects: no one
is stopping your from testing and using other projects. If you feel
like it, just go ahead!

FLV video files can embed some sound, you just need to put the correct
kind of audio. This should get your started:


Reinventing the wheel certainly is annoying, but as long as all other
wheels are square...

Reimar D?ffinger

More information about the ffmpeg-devel mailing list