[Ffmpeg-devel] [PATCH] dv pixel format encoding fix

Roman Shaposhnick rvs
Fri Mar 10 07:38:46 CET 2006

On Thu, Mar 09, 2006 at 05:13:11PM +0100, Baptiste COUDURIER wrote:
> Hi,
> Here is a patch to fix pixel format while encoding in dv.
> SMPTE 314M defines 411P and 422P, and specifies atp as 1. Appendix A
> shows that IEC 61834 used 0 as atp. SMPTE 314 specifies STYPE to be 1
> for 422P and 0 for 411P, I assume 420 is 0.

  All this is fine, but I thinks this is really getting to a point where
  this has to be per profile. For example, your patch doesn't take into
  account the fact that encoding 411P for NTSC could mean either IEC 61834
  or SMPTE 314. The VAUX STYPE is also not quite clear for IEC 61834.
  I'll have to either try digging up something resembling an IEC spec
  or look at the IEC 61834 raw output. Stay tuned ;-) 

> I still have problems with DV in MOV since I could not figure out yet
> where atp is set in codec encoding functions. Roman could you help me on
> this one ?

  I can -- it is currently set by the DV container ;-)

> It seems since you removed the profile check, encoding with incorrect
> pix_fmt or resolution produces 0 bytes frames.

  I know. Will take care of this on weekend.

> I think that this check should really be resurrected until codec
> restrictions are handled differently, at least for encoder, else it's
> hard to figure out that something went wrong, what do you think ?

  I agree. However, see my other concerns in reply to Michael's email
  in this thread.


More information about the ffmpeg-devel mailing list