[Ffmpeg-devel] mac intel compilation problems

James Barros james
Tue Mar 14 21:22:29 CET 2006

Hi kids,

So I went out and got a new intel mac (great idea! :( ) and now  
everything is broken. Amongst these things is ffmpeg. I appologize in  
advance if this question has been answered before, but I tried  
reading over the archives (are those searchable somehow?) and  
googling, and came up with what I thought was the right way to do it,  
and failed.

First I rebuilt lame and faac. No problems there.

I grabbed the latest version of ffmpeg from the CVS and configured as  

./configure --enable-mp3lame --enable-gpl --enable-faac --extra- 
cflags=-DHAVE_LRINTF --enable-static --disable-shared --disable-mmx

which is what I gathered I needed to do to make it work with the  
intel macs.
config went fine, but the make died as follows.

(only including the tail end of the make, so as not to overload the  
list. if I should send the full results of the make, please let me know)

cc -Wl,-dynamic,-search_paths_first -g -o ffplay_g ffplay.o  
cmdutils.o -L./libavformat -lavformat -L./libavcodec -lavcodec -L./ 
libavutil -lavutil -lmp3lame -lfaac -lz  -L/opt/local/lib -lSDLmain - 
lSDL -framework Cocoa -framework OpenGL
/usr/bin/ld: warning /opt/local/lib/libfaac.dylib cputype (18,  
architecture ppc) does not match cputype (7) for specified -arch  
flag: i386 (file not loaded)
/usr/bin/ld: Undefined symbols:
collect2: ld returned 1 exit status
make: *** [ffplay_g] Error 1
james-computer:~/sw/ffmpeg jbarros

so it appears that somewhere it's still got ppc vs x86 issues.

I apologize for my ignorance.

Thank you for your help.


James Barros

More information about the ffmpeg-devel mailing list