[Ffmpeg-devel] [BUG] Regression test failure since r6412

Panagiotis Issaris takis.issaris
Mon Oct 2 15:26:03 CEST 2006


There appears to be a problem with the regression tests with the current SVN code:

--- ./data/ffmpeg.regression    2006-10-02 13:49:20.000000000 +0200
+++ /usr/local/src/ffmpeg/tests/ffmpeg.regression.ref   2006-09-04 13:03:41.000000000 +0200
@@ -81,8 +81,8 @@
 stddev: 12.32 PSNR:26.31 bytes:7602176
 670f6e540bcf504ccc72d41952cc401e *./data/a-mpeg4-Q.avi
 900488 ./data/a-mpeg4-Q.avi
-4b5d15d8ac56fb1444e79131aa67a7e6 *./data/out.yuv
-stddev:  5.70 PSNR:33.00 bytes:7602176
+af59c063ed644c7dc4151a0a2debbddd *./data/out.yuv
+stddev:  5.69 PSNR:33.00 bytes:7602176
 b8da412bd5421c6ac6fcb6c9caa261ae *./data/a-mpeg4-PSP.mp4
 407313 ./data/a-mpeg4-PSP.mp4
 ef45e577219460332bed428106f638a6 *./data/a-error-mpeg4-adv.avi

Regression test: Error.
make[1]: *** [codectest] Error 1
make[1]: Leaving directory `/usr/local/src/ffmpeg/tests'
make: *** [test] Error 2

git-bisect told me r6412 was the first revision breaking it: 
"approximate qpel functions: sacrifice some quality for some decoding speed. enabled on B-frames 
with -lavdopts fast."

The regression tests were also broken in r6411, but that was a differetn problem
and has already been fixed:
--- data/ffserver.regression    2006-10-02 15:13:55.000000000 +0200
+++ /usr/local/src/ffmpeg/tests/ffserver.regression.ref 2006-08-21 10:34:49.000000000 +0200
@@ -1,8 +1,8 @@
 418d0c843a6605a7d48f285804a69df4  ff-test_h.avi
 ad4605187044d5e169f32a2ea205f937  ff-test_l.avi
 34f4f0c160efcdb37c0999680e07c41c  ff-test.swf
-fe6de6234a8bb4ace52b86763741cecd  ff-test_h.asf
-68e7c8a8ff64c4016a8d4e5ea27353f3  ff-test_l.asf
+1eb3fdf04c43c8b0cc59d8444c0f2af3  ff-test_h.asf
+ffa9d3708aa394fd3631c002fc6cc088  ff-test_l.asf
 cba8663681bf3ef89c95c09bb90204db  ff-test_h.rm
 0a14086c708a7b8f4604e705a2bb7087  ff-test_l.rm
 353a9a8fb3d5bb2334ac991b5c60f6d3  ff-test.jpg

Server regression test: Error.

With friendly regards,

More information about the ffmpeg-devel mailing list