[Ffmpeg-devel] ARCH_X86 vs ARCH_X86_32 vs ARCH_X86_64
Sun Oct 8 23:55:55 CEST 2006
I'd like to introduce a define that encompasses both x86 and x86_64 to
simplify statements like
#if defined(ARCH_X86) || defined(ARCH_X86_64)
of which we have tons in the code and be able to use it in the Makefiles
where or expressions are troublesome.
My first idea was to rename ARCH_X86 --> ARCH_X86_32 and use ARCH_X86
for the general case. It seems like the cleanest and most
straightforward solution to me, but I'm getting second thoughts. I'm
afraid that ARCH_X86 semantics are kind of set in stone through years of
usage (in autoconf as well).
More information about the ffmpeg-devel