[Ffmpeg-devel] [PATCH] Don't use --as-needed for every operatingsystem

Diego 'Flameeyes' Pettenò flameeyes
Sat Oct 21 21:55:05 CEST 2006

On Tuesday 17 October 2006 00:08, V?ctor Paesa wrote:
> Right, --as-needed is not needed under Cygwin (at least with ld 2.17.50).
> The option seems ignored (no warnings generated).
> And -rpath-link is also ELF specific, equally ignored here.
Well -rpath-link is ELF specific but at least has a sense for other operating 
systems than Linux, and should be non-disruptive for other systems.

Can someone please take a look to the patch? The current SVN without that is 
going to simply fail on FreeBSD systems with recent enough binutils.

Diego "Flameeyes" Petten? - http://farragut.flameeyes.is-a-geek.org/
Gentoo/Alt lead, Gentoo/FreeBSD, Video, Sound, ALSA, PAM, KDE, CJK, Ruby ...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20061021/9b8f74b0/attachment.pgp>

More information about the ffmpeg-devel mailing list