[Ffmpeg-devel] FreeBSD 6.1 amd64 and current SVN

Tatu Kilappa trilkk
Sun Oct 22 18:25:50 CEST 2006

I tried to compile the current version with a FreeBSD-6.1-amd64
machine, and ran into some problems.

First of all, the easy one. libavcodec/grab_bktr line 28 has a

# if __FreeBSD__ >= 502100

This tests for the ioctl_meteor.h and ioctl_bt848.h location on newer
FreeBSD revisions. However, __FreeBSD__ equals 6 in 6.1, which will
cause the compilation to fail. Changing the line to

# if __FreeBSD__ >= 502100 || __FreeBSD__ == 6

fixes the problem.

Also, search from /usr/local/include and /usr/local/lib is not enabled
by default, which will cause ALL configure probes to fail, but this is
probably an user (mine) error, as people should probably have
-I/usr/local/include and -L/usr/local/lib in their C- and LDFLAGS.

You could also add a note in the FAQ about the link order. If an user
is stupid enough to issue `pkg-config --libs avcodec` and `pkg-config
--libs avformat` simultaneously, this will cause the linking to fail
crypticly, as -lavutil is in the command line before -lavformat. It took
me quite a while to figure out I only need to check for avformat.

-Tatu Kilappa <trilkk at iki.fi>

More information about the ffmpeg-devel mailing list