[Ffmpeg-devel] About A/V Sync problem after transcoding via FFMPEG

Sean Zheng seanzhen
Tue Oct 24 04:38:03 CEST 2006

On 10/24/06, M?ns Rullg?rd <mru at inprovide.com> wrote:
> "Sean Zheng" <seanzhen at gmail.com> writes:
> > Hi, I've transcoded a H.263 V1 Video from FLV by FFMPEG via the
> > following command:
> >
> > ffmpeg -i flvtest.flv -s 704x576 -f vob -vcodec h263 -acodec mp3 h263pstest.mpg
> >
> > I use the VOB encapsulation method (MPEG PS),
> Don't do that.  MPEG PS doesn't support h263 video.  The PS muxer
> should be fixed to give an error if you try.

Oh, why doesn't it support h263 video? As I know, the MPEG PS is only
an encapsulation method, I think any video codec can be encapsulated
in this method, isn't it?

> > but I find that the Audio and Video isn't synchronized while playing
> > the result video.  and the audio is discontinuous.
> How do you play that file?  No player I know of will detect h263 video
> in MPEG PS, and neither should they.  Does it work with MPEG2 video?

I play the result video via hardware decoder--VWeb 2010.
The firmware supports the result video except for the A/V sync problem.

> > But if I use the MP4 encapsulation, the Audio and Video is
> > synchronized while playing the video:
> >
> > ffmpeg -i flvtest.flv -s 704x576 -f mp4 -vcodec h263 -acodec mp3 h263mp4test.mpg
> >
> > Any suggestions are highly appreciated.
> Use MOV, MP4, or whatever it's called today.

is there any way for using MPEG PS format?
it seems that there is only the A/V Sync problem for playing the result video.

> --
> M?ns Rullg?rd
> mru at inprovide.com
> _______________________________________________
> ffmpeg-devel mailing list
> ffmpeg-devel at mplayerhq.hu
> http://lists.mplayerhq.hu/mailman/listinfo/ffmpeg-devel

More information about the ffmpeg-devel mailing list