[Ffmpeg-devel] Latest SVN failing to configure

Pavlov Konstantin thresh
Tue Oct 24 23:06:18 CEST 2006

On Tuesday 24 October 2006 23:52, Aaron Williams wrote:
> I'm a bit sorry about the tone of my last email.  The problem in configure
> seems to be caused by the addition of -Wl,--as-needed.  This seems to
> somehow make the order of the libraries important, or else it breaks
> something in the linker.  In my testing, if I remove this, I no longer
> need to add -lm after -ldts.

Yes, you're completely right about this. For more info, please check info ld 
for --as-needed option - it will explain the behaviour.

Pavlov Konstantin,
CPMS Network,
jid: thresh at altlinux.org

More information about the ffmpeg-devel mailing list