[Ffmpeg-devel] Streaming from camera segfaults on Ubuntu Dapper

Luca Abeni lucabe72
Thu Oct 26 22:46:22 CEST 2006

Hi Timo,

first of all, sorry for the late reply.

On Tue, 2006-10-24 at 18:12 +0300, Timo Rantalaiho wrote:
> Hello Luca,
> On Sun, 22 Oct 2006, Luca Abeni wrote:
> > Since this segfault might involve the v4l2 input format, I am interested
> > in the bugreport. Can you provide a backtrace, as indicated at
> > http://ffmpeg.mplayerhq.hu/bugreports.html ?
> Do you mean the gdb output that I posted earlier:
>   http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2006-October/046476.html
Ops... Sorry, I missed it :)
I've been quite busy, and I overlooked that email. Sorry about that, and
thanks for your patience.

> > Also, I just committed a more strict check on some parameters returned
> > by the v4l2 driver... Can you do a "svn update" and repeat the test?
> Yes, and now the behaviour changed! There is a more verbose
> error message "The v4l2 frame is 460800 bytes, but 115200 bytes are
> expected".
Ok, this is giving us some more information...

The driver is claiming that it is returning a frame of size 460800...
Maybe I misunderstood the v4l2 specifications, but this looks wrong to
me (if I am not wrong, 460800 should be the buffer size for a 640x480

I unfortunately have no time now, but on monday I'll study this problem,
and hopefully find a fix (if anyone has any hint about this driver's
behaviours, ideas are welcome).


More information about the ffmpeg-devel mailing list