[Ffmpeg-devel] Problem linking in dts with shared version - should link dts_pic instead of dts.

Ismail Donmez ismail
Sun Oct 29 22:14:17 CET 2006

29 Eki 2006 Paz 23:10 tarihinde, Aaron Williams ?unlar? yazm??t?: 
> Problem linking with --enable-shared
> When compiling the shared version of ffmpeg I get an error when it tries
> to link libavcodec.so.  It's trying to link in dts (-ldts) when it
> should link in dts_pic in this case (-ldts_pic).

That looks amd64 and distro spesific :

[~]> ls -1 /usr/lib/libdts.*

I guess its linking to libdts.a instead of libdts_pic.a ?


More information about the ffmpeg-devel mailing list