[Ffmpeg-devel] Compiling on Solaris 10

may nothing may_241913
Sat Sep 16 19:12:25 CEST 2006

Hi Roman,

I used a simple shell script to grep BE_16 in all ffmpeg files and run 'sed s /BE_16/FF_BE_16/g'
That fixed the problem. Maybe we should introduce this as a permanent change ...


----- Original Message ----
From: Roman Shaposhnick <rvs at sun.com>
To: FFMpeg development discussions and patches <ffmpeg-devel at mplayerhq.hu>
Sent: Saturday, September 16, 2006 1:49:42 AM
Subject: Re: [Ffmpeg-devel] Compiling on Solaris 10

On Fri, 2006-09-15 at 19:22 -0400, Christian Bienia wrote:
> Hi,
> I get syntax errors when I try to compile ffmpeg with gcc 3.4.3 on
> Solaris 10. Here's the output:
> It seems to be related to the macro BE_16, but I couldn't figure out
> what's wrong. I don't get that error with Fedora Core 4. Has anybody
> tried to compile ffmpeg on Solaris?

  Obviously if you look at my email you can guess that I tried. In fact
on of these days I should really make it Solaris compatible once again.

But anyway, the problem you see, stems from the fact that on Solaris
we've got: /usr/include/sys/byteorder.h that defined the same macro.
Hence the collision.

If you're interested in working on a patch to make it Solaris 10
friendly -- feel free to contact me.


ffmpeg-devel mailing list
ffmpeg-devel at mplayerhq.hu

More information about the ffmpeg-devel mailing list