[Ffmpeg-devel] [BUG] Core dump on Solaris

Christian Bienia cbienia
Tue Sep 19 23:40:10 CEST 2006


the thread code of ffmpeg's mpeg4 encoder seems to be broken. Whenever I
use more than one thread, I get the following error:

ffmpeg -f image2 -i 02350.png -threads 2 test.mp4
FFmpeg version SVN-rUNKNOWN, Copyright (c) 2000-2004 Fabrice Bellard
  configuration:  --enable-pthreads --enable-a52 --enable-gpl
--disable-ffserver --disable-ffplay --prefix=/home/cbienia/ffmpeg 
  libavutil version: 49.0.0
  libavcodec version: 51.14.0
  libavformat version: 50.5.0
  built on Sep 19 2006 18:14:59, gcc: 3.4.3
Input #0, image2, from '02350.png':
  Duration: 00:00:00.0, start: 0.000000, bitrate: N/A
  Stream #0.0: Video: png, rgb24, 640x360, 25.00 fps(r)
Output #0, mp4, to 'test.mp4':
  Stream #0.0: Video: mpeg4, yuv420p, 640x360, q=2-31, 200 kb/s, 25.00
Stream mapping:
  Stream #0.0 -> #0.0
Press [q] to stop encoding
Bus Error (core dumped)

The error only occurs on Solaris 10 if more than 1 thread is used. The
other platforms I tried seem to work fine. The input data is taken from
the open source movie "Elephants Dream", it can be downloaded from here:


I ran ffmpeg in dbx, and core dump always happens in

t at 2 (l at 2) signal BUS (invalid address alignment) in
ff_mpeg4_encode_video_packet_header at 0x175154
0x00175154: ff_mpeg4_encode_video_packet_header+0x01dc: st       %l1,

- Chris

More information about the ffmpeg-devel mailing list