[Ffmpeg-devel] Possible bug in reading PTS/DTS

Michael Niedermayer michaelni
Mon Apr 23 12:41:23 CEST 2007


On Mon, Apr 23, 2007 at 12:20:17PM +0200, Michel Bardiaux wrote:
> Luca Abeni wrote:
> > Hi Michel,
> > 
> > Michel Bardiaux wrote:
> > [...]
> >>> (If the problem really is in the user application, I can prepare and 
> >>> send a patch fixing ffmpeg.c and ffserver.c)
> >>>
> >>> Or maybe the problem is in my (mis)understanding of this issue?
> >> I'm not sure the problem is in decoding. I find it rather strange that 
> >> the first frame, which is a keyframe, does not have PTS=DTS.
> > I do not know... I see that for containers that store both PTS and DTS, 
> > ffmpeg generally generates
> > DTS = PTS - frame period
> > for video (I am not using B frames, to simplify the testing). Is this 
> > wrong? If yes, then I think there is something to fix in the encoding / 
> > muxing side.
> I think so too. My reading of the spec is that in the absence of 
> B-frames, the DTS are not even necessary; I'm afraid there is something 
> very wrong in the MPEG muxer. 

nonsense, dts==pts for mpeg1/2/4 b frames _always_ and pts>dts for i/p frames
unless the stream is low delay but this is rare


Michael     GnuPG fingerprint: 9FF2128B147EF6730BADF133611EC787040B0FAB

Everything should be made as simple as possible, but not simpler.
-- Albert Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070423/4f72abfb/attachment.pgp>

More information about the ffmpeg-devel mailing list