[Ffmpeg-devel] Possible bug in reading PTS/DTS

Luca Abeni lucabe72
Mon Apr 23 12:58:42 CEST 2007

Hi Michael,

Michael Niedermayer wrote:
> Hi
> On Mon, Apr 23, 2007 at 09:58:26AM +0200, Luca Abeni wrote:
>> Hi all,
>> I found a "strange feature" in ffmpeg. Basically, in some cases video 
>> PTSs and DTSs read from a stream have a strange offset respect to audio 
>> timestamps (I noticed this problem when trying to debug a strange 
>> ffserver behaviour, but the problem appears in ffmpeg.c too).
> does reverting r8465 fix this?
Yes, you are right. I reverted it by applying the attached patch (I 
attach it just to be sure that I did not revert the wrong thing), and 
everything works fine now.

> if yes you have my approvial to revert this in svn
Ok good. Can I revert it by simply applying the attached patch (with a 
chagelog explaining why this has been reverted), or should I use some 
"svn cp" magic? (since there are other commits on utils.c after 8465, I 
am not sure if "svn cp" can work)

BTW, has the error addressed by r8465 been fixed in some other way, or 
will it be re-introduced by reverting the commit (I do not want the 
responsibility of reintroducing a fixed bug :)?

I'll wait 1 day or 2, to give Wolfram the possibility to comment on 
this, then I'll apply the patch.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: r8465.diff
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070423/9a23bacf/attachment.txt>

More information about the ffmpeg-devel mailing list