[Ffmpeg-devel] libswscale coding style
Fri Apr 27 22:02:14 CEST 2007
On Friday 27 April 2007 21:41, Trent Piepho wrote:
> On Fri, 27 Apr 2007, Diego Biurrun wrote:
> > On Fri, Apr 27, 2007 at 12:29:28PM +0200, Ivo wrote:
> > > I would really like to see the "instr op, op\n\t" be replaced by
> > > something more readable, like:
> > >
> > > " movq %%mm0, %%mm1 \n"
> > > " movq %%mm1, %%mm2 \n"
> > > " punpckldq 9%1, %%mm1 \n"
> > Where did the \t go to? No, I have no idea about Assembler ..
> He's padding it with some spaces in the beginning. I like the \t at the
> end better, as the asm gcc emits uses a tab. When writing asm, I often
> end up looking at gcc's asm output, and it's easier to read when the
> inline asm is nicely formatted against the gcc generated asm.
I like it to stand out of the generated assembly :) I know I can look for
APP/NO_APP but I can spot it faster if it is indented differently. But
perhaps we can find a compromise, something like:
[ . . . . . . . . . ]
"movq %%mm0, %%mm1 \n\t"
"punpckldq 9%1, %%mm1 \n\t"
etc... I find the added whitespace for readability more important than the
indentation with spaces.
More information about the ffmpeg-devel