[FFmpeg-devel] Autodetecting support for "PRId64"

Diego Biurrun diego
Mon Dec 3 11:51:47 CET 2007

On Mon, Dec 03, 2007 at 11:16:28AM +0100, carlo.bramix wrote:
> I tried to compile ffmpeg for working under AROS (see http://aros.sourceforge.net for more details) but I had some initial troubles.
> The problem was caused by the unrecognized "PRId64" escape from my GCC.
> Actually I solved it by adding this line:
> -DPRIx64=\"%llx\" -DPRId64=\"%lld\" -DPRIu64=\"%llu\" -DPRIdFAST16=\"%hd\" -DPRIdFAST32=\"%ld\"
> to OPTFLAGS into generated config.mak.
> I also discovered that it could also be done by adding them with "--extra-cflags" to configure script.
> However, my suggestion for the future would be a simple, quick test at configure time for adding this line automatically.
> It would be nice that configure will do a:
> "checking /"PRId64/" support..."
> and if it isn't detected it will add the fix.
> I understand that it can be fixed manually as I did, but afterall the
> computer has been made for working instead the man, so why not doing it?

How about fixing AROS?  You just need to add those definitions to the
proper system header, inttypes.h I think.


More information about the ffmpeg-devel mailing list