[FFmpeg-devel] [PATCH] add alloc_put_byte function

Baptiste Coudurier baptiste.coudurier
Thu Dec 20 23:58:32 CET 2007


Michael Niedermayer wrote:
> On Wed, Dec 19, 2007 at 10:48:50PM +0100, Michael Niedermayer wrote:
>>On Wed, Dec 19, 2007 at 07:47:45PM +0100, Reimar D?ffinger wrote:
>>>since applications should not assume ByteIOContext to have a constant
>>>size, attached patch adds a alloc_put_byte function.
>>>It is almost the same as init_put_byte, but it also takes a
>>>streamed_flag parameter - this seems the only missing option the user
>>>has a reason to set and it's exactly what I need, so like this
>>What about read_pause / read_seek ?
>>Some things like MMS do not support seeking per positon AFAIK, and seeking
>>per timestamp needs read_seek()
>>Iam just curious, dont you consider that needed/usefull as well?
>>Same for the ability to pause (tell the server not to send more packets)
> Well i guess the question of which arguments the function should take is
> mostly bikeshed. So iam fine with the patch except that the function needs
> a av_ prefix

For consistency, can we choose a naming convention ?

We got:

Furthermore, ByteIOContext can be used to read data, so naming it
alloc_put_byte seems somehow odd to me.

I'd prefer something like av_alloc_byteio_context.

Baptiste COUDURIER                              GnuPG Key Id: 0x5C1ABAAA
SMARTJOG S.A.                                    http://www.smartjog.com
Key fingerprint                 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
Phone: +33 1 49966312

More information about the ffmpeg-devel mailing list