[FFmpeg-devel] [PATCH] add alloc_put_byte function
Sat Dec 22 23:38:32 CET 2007
Reimar D?ffinger a ?crit :
> On Fri, Dec 21, 2007 at 09:49:05AM +0100, Reimar D?ffinger wrote:
>> On Thu, Dec 20, 2007 at 11:58:32PM +0100, Baptiste Coudurier wrote:
>>> For consistency, can we choose a naming convention ?
>>> We got:
>>> Furthermore, ByteIOContext can be used to read data, so naming it
>>> alloc_put_byte seems somehow odd to me.
>> I just went on analogy to init_put_byte, I don't like it particularly
>> either. I'll go with anything you agree on ;-)
> Applied with only av_ prefix added, I do not want to wait forever with a
> depending patch.
> Feel free to come up with a better name and then bump the lavf version
> (I originally just forgot to do it, but now think it might be good as it
> give as chance to change the name without breaking API in the strict
> sense ;-) ).
Ok, I already suggested av_alloc_byteio_context, anyone against it ?
Baptiste COUDURIER GnuPG Key Id: 0x5C1ABAAA
Key fingerprint 8D77134D20CC9220201FC5DB0AC9325C5C1ABAAA
checking for life_signs in -lkenny... no
More information about the ffmpeg-devel