[Ffmpeg-devel] Bug? Subtitles not detected in vob

Erik Slagter erik
Mon Jan 8 12:58:31 CET 2007


I am trying to convert a vob (from DVD) to a transport stream, for use
on a sat top box. The sat top box can play vobs (although without
subtitles) and transport streams (including those created with ffmpeg,
and including subtitles).

The first thing I run into is that ffmpeg doesn't even detect the
subtitles in the vob file. I both tried increasing the -probesize to the
max and cutting off multiples of 2048kb off the vob so the vob
immediately starts with a section actually containing subtitles. None of
these help.


artemis erik:~/apache/erik/pub $ ffmpeg -probesize 1000000000 -i test2.vob
FFmpeg version SVN-r7425, Copyright (c) 2000-2006 Fabrice Bellard, et al.
  configuration:  --prefix=/usr --libdir=/usr/lib64
--shlibdir=/usr/lib64 --enable-mp3lame --enable-faad --enable-faac
--enable-x264 --enable-a52 --enable-pp --enable-static --enable-shared
--enable-amr_nb --enable-amr_wb --enable-amr_if2 --enable-pthreads
--enable-gpl --disable-audio-oss --disable-v4l --disable-v4l2
--disable-bktr --disable-dv1394 --disable-debug --arch=x86_64
--cpu=nocona --extra-cflags=-m64 --extra-ldflags=-m64 --enable-swscaler
  libavutil version: 49.1.0
  libavcodec version: 51.28.0
  libavformat version: 51.7.0
  built on Jan  8 2007 12:33:42, gcc: 4.1.1 20060525 (Red Hat 4.1.1-1)
Input #0, mpeg, from 'test2.vob':
  Duration: 00:00:20.3, start: 112.180000, bitrate: 8047 kb/s
  Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x576, 8700 kb/s,
25.00 fps(r)
  Stream #0.1[0x81]: Audio: ac3, 48000 Hz, 5:1, 384 kb/s
  Stream #0.2[0x80]: Audio: ac3, 48000 Hz, 5:1, 384 kb/s
Must supply at least one output file

The title contains at least three subtitle tracks, 1,2 being French and
3 being Dutch. Using mplayer -sid x this is confirmed.

The relevant snippet (20 Mb) (edited on 2kb boundaries) can be
downloaded from here:


I can also supply a version with the initial part intact.


More information about the ffmpeg-devel mailing list