[Ffmpeg-devel] Cross Compiling to Windows CE

Ramiro Polla angustia
Wed Jan 17 03:38:34 CET 2007

Cool_Zer0 wrote:
> Alexander Chemeris wrote:
>> On 1/16/07, Cool_Zer0 <c00jz3r0 at gmail.com> wrote:
>>> Well...
>>> I don't know what's the problem now :(
>>> I have the .lib files (avutil-49.lib, avcodec-51.lib and 
>>> avformat-51.lib)
>>> and I successfully have compiled and linked my project on MSVC++...
>>> I've deployed the file to my device and put the 3 dll's on the same 
>>> folder (
>>> avutil-49.dll, avcodec-51.dll and avformat-51.dll)...
>>> The program keeps telling me that a file is missing and I can't 
>>> understand
>>> what it is...
>> Use any "dependency" tool to see which dll's imported by your program.
>> Common problem here - you've linked against debug C/C++ runtime DLLs,
>> which does not supplied with Windows.
> Yep... That's it... I need the DLL's off the cross compiler...
> Now it says that my application is not a Pocket PC valid application...
> I'm checking with the cross compiler guys if it's a problem of the 
> cross compiler or ffmpeg...
> I think that there are some failures on the "make" process when using 
> --enable-mingwce... The "lib.exe" (of VC++) command uses the parameter 
> "/machine:i386" and I think that it should be "/machine:arm"...
How about this patch?

Ramiro Polla
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: wince_1.diff
URL: <http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/attachments/20070117/8b289671/attachment.asc>

More information about the ffmpeg-devel mailing list