[Ffmpeg-devel] [PATCH] install libavformat/riff.h

Aurelien Jacobs aurel
Sat Jan 20 23:28:41 CET 2007


On Sat, 20 Jan 2007 22:31:40 +0100
Nico Sabbi <nicola_sabbi at fastwebnet.it> wrote:

> Michael Niedermayer wrote:
> 
> > 
> > nico, just give the ones mplayer needs an av_ prefix and move them to
> > avformat.h or split riff.h into riff.h+riff_internal.h
> > 
> > 
> 
> let's see: I'd move to riff_internal.h
> 
> offset_t start_tag(ByteIOContext *pb, const char *tag);
> void end_tag(ByteIOContext *pb, offset_t start);
> 
> void put_bmp_header(ByteIOContext *pb, AVCodecContext *enc, const 
> CodecTag *tags, int for_asf);
> int put_wav_header(ByteIOContext *pb, AVCodecContext *enc);
> int wav_codec_get_id(unsigned int tag, int bps);
> void get_wav_header(ByteIOContext *pb, AVCodecContext *codec, int size);
> 
> 
> 
> 
> and to riff.h (prepended by ff_):

AFAIK prefix should be av_ instead of ff for external API.

> typedef struct CodecTag {
>      int id;
>      unsigned int tag;
>      unsigned int invalid_asf : 1;
> } CodecTag;
> 
> 
> extern const CodecTag ff_codec_bmp_tags[];
> extern const CodecTag ff_codec_wav_tags[];
> 
> unsigned int ff_codec_get_tag(const CodecTag *tags, int id);
> enum CodecID ff_codec_get_id(const CodecTag *tags, unsigned int tag);
> unsigned int ff_codec_get_bmp_tag(int id);
> unsigned int ff_codec_get_wav_tag(int id);
> enum CodecID ff_codec_get_bmp_id(unsigned int tag);
> enum CodecID ff_codec_get_wav_id(unsigned int tag);
> unsigned int ff_codec_get_asf_tag(const CodecTag *tags, unsigned int id);
> void ff_parse_specific_params(AVCodecContext *stream, int *au_rate, 
> int *au_ssize, int *au_scale);

Is it necessary to export parse_specific_params() ?
If so, maybe it should be renamed ? This name don't give me any
clue about the purpose of this function.

Aurel




More information about the ffmpeg-devel mailing list