[FFmpeg-devel] GPL version matter

Reimar Döffinger Reimar.Doeffinger
Sun Jul 1 01:07:11 CEST 2007

On Sat, Jun 30, 2007 at 10:37:10PM +0100, M?ns Rullg?rd wrote:
> Uoti Urpala <uoti.urpala at pp1.inet.fi> writes:
> > On Sat, 2007-06-30 at 22:19 +0200, Christophe GISQUET wrote:
> >> Indeed I missed it, thinking 2.1 was a matter of phraseology. I
> >> generally don't make my choices on absolute confidence in a sunny
> >> future, or more tersely, that I will like any GPL versions coming out
> >> any day.
> >> 
> >> > so even without the "(at your option) any later version."
> >> > anyone can take your LGPL 2.1 code and change it to GPL 12.3.4
> >> 
> >> Then let my obvious question after that obvious correction be:
> >> Are contributions under the strictly version 2 GPL accepted?
> >
> > Given that GPL 3 has already been released and is no longer an unknown
> > "any GPL version coming out any day", do you explicitly want to forbid
> > use under it?
> There are parts of the new GPL3 that I'm not really comfortable with.
> That said, I'm not usually the one to let philosophical/political
> matters get in the way of things.

Well, actually is the discussion about GPL or LGPL now anyway? It first
was LGPL 2.1 or later, then LGPL 2.1 only, to which Michael replied it
would allow relicensing to GPL y.x, so is it now _only_ GPL, _not_ LPGL
_and_ only v2? (and do we want our users to deal with that kind of

Reimar D?ffinger

More information about the ffmpeg-devel mailing list