[FFmpeg-devel] GPL version matter

GISQUET Christophe christophe.gisquet
Thu Jul 5 20:08:10 CEST 2007

Good evening,

Diego Biurrun a ?crit :
> I would really appreciate it if you could contribute this under LGPL,
> like the rest of FFmpeg.  We are not talking about a big piece of code
> and as you may have seen from the thread, it might cause quite a bit of
> a stir in the project...

I've triple-licensed that code under GPL 2 and 3, and LGPL3, strict version 
numbers. If the versioning is troublesome to you, then let it only be 
available under GPL, that is until a new revision of the {L,}GPL is out for my 
inspection. I still strongly disagree with the "a version -> any version" of 
the LGPL2.x, and have already put aside my dislike for v3 to allow such license.

As for the stir, I'm indeed sorry if that is considered as noise (even more if 
due to my being clueless), but it made things at least clearer for this small 
contribution, and somewhat for the ffmpeg project.

If the integration uses it only as GPL code, then I can update the patch with 
the required additional conditional(s).

Best regards,
Christophe GISQUET

More information about the ffmpeg-devel mailing list