[FFmpeg-devel] [PATCH] matroska subtitle tracks support
Tue Jul 10 18:51:20 CEST 2007
Michael Niedermayer wrote:
> On Tue, Jul 10, 2007 at 01:29:11PM +0200, Aurelien Jacobs wrote:
>> On Tue, 10 Jul 2007 11:01:48 +0100 (BST)
>> M?ns Rullg?rd <mans at mansr.com> wrote:
>> > Aurelien Jacobs wrote:
>> > > Indeed, I agree with this. So maybe CODEC_ID_PLAIN_TEXT ?
>> > "PLAIN" differentiating it from what? If we wanted an ID for, say, HTML
>> > I'd suggest CODEC_ID_HTML etc. When no ambiguity exists, shorter names
>> > should be preferred. This is not Java.
>> That's fine with me. If Michael is ok, I will use CODEC_ID_TEXT.
> well, iam not opposed to CODEC_ID_TEXT though i still feel that
> SUBTITLE should be part of the name but i am fine with CODEC_ID_TEXT
> too if you prefer
Why? We don't have CODEC_ID_H264_VIDEO or CODEC_ID_AC3_AUDIO. I fail
to see what makes subtitles special. We have to use CODEC_ID_DVB_SUBTITLE
since that encoding has no other non-ambiguous name.
mans at mansr.com
More information about the ffmpeg-devel